Installing on Mac


I follow the instructions and try to ssh the pi but nothing happens.

I suspect that something happens, but not what you want. :slight_smile:

You don't say what you want to achieve by using ssh?

Typically I just open a web browser pointing at octopi.local (about half
the time that auto-completes to but that's not important right

So, first, log in to your router and see if the Pi has connected to your
router. (probably

Then try ssh to the IP address (I find ssh -Y is more reliable, especially
if you want to open remote X windows)

And then you can try octopi.local.


I spoke too soon. I cannot SSH to the Raspberry Pi from laptop. It is a Macbookpro.


*I am using a Macbookpro and cannot SSH or log in from Chrome.

I have a 7 inch screen and see the boot chase across the screen ending in "pi@octopi:~%~.

I changed the wifi SSID and password. I set up the config to take SSH but I am not sure that copied over. I use Etch app to burn the card. Your help will be appreciated.


@Henry_Staub please do not open multiple topics on the same problem


You may have seen my last post but despite having the Pi boot I cannot SSH in. Does the display attached to the PI display the main page. Where is Octopi running? It seems like it must be an individual instance with each Octoprint setup. This is confusing.

Henry Staub


Henry Staub


I tried to find the IP address 'ip addr show' and got back a lot of cryptic telling me there was no loop back and a strange address (127.0.01/8). Any ideas?


What are your (uncommented) entries in /boot/octopi-network.txt and /boot/octopi-wpa-supplicant.txt? "I didn't edit those files" is a valid response.


BTW, here's an example of a good IP address in ip addr show, it's the entry:

3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether b8:27... brd ff:ff:...
    inet brd scope global wlan0
       valid_lft forever preferred_lft forever
    inet6 fe80::42d8.../64 scope link
       valid_lft forever preferred_lft forever


I did not edit them.


It can't connect to your network unless you configure that (or are using an Ethernet cord).


OK that means the wifi dongle NG. I plugged in a ethernet cable and it gave me the IP address and whamo we get the screen on the laptop. Now I guess I get to hook up the printer cable to thePi and see what happens. Thanks.

Henry Staub


OK I got every thing ready to print and Wham it wants an API key. OK I did look but cannot find how to get one. Help Please.


In settings, in the features subsection, there's an entry for API.


@Henry_Staub - did you ever get your WiFi working, or are you access via ethernet or using your connected screen. If you have not edited your WiFi information in either octopi-network.txt or octopi-wpa-supplicant.txt as @tedder42 mentioned, your WiFi will not work (if you are using an ethernet caple to connect your pi to your router, this is not a big deal. If you are not, you will not be able to access OctoPrint or access your Pi via ssh.) Take a look at this thread for WiFi help


No I am still on ethernet. I need help with an number of things. Change password. do something with API password, and generally how to navigate thru directories and find stuff.


I am using ethernet to the Pi and SSH-ing from MacBook with wifi. I can pull up the Octo print page on the browser. I clicked on a little wrench and a whole new world opened up.

I am using the Lulzbot Mini and it uses a variant of Cura. I even found API code which I plugged into Cura hoping to use Cura but it does not want to connect to the printer from the laptop remotely. Wonder what I need to do?

Henry Staub


Check the thread I linked in my previous response for help getting your Pi's WiFi working.

I can't help much with the API thing. I also have a Lulzbot Mini. I have not upgraded to the new version of Cura on my Mac, since it requires flashing a new firmware to the printer. If I do that, I can use Cura on my Mac to access the printer through OctoPrint, but then I can no longer slice from within OctoPrint (which uses the older version of Cura). Since I need to slice within OctoPrint when using the printer at the school where I volunteer. There is a work-around for this so I can use both with the new firmware on the Mini, but I haven't worked my way through it yet. If you only slice on Cura on your Mac, there is no need to worry about this. You should just be able to install the new version of Cura, flash the firmware and go.


Try hardcoding the IP address instead of using octopi.local. But before using the API, just upload the gcode, which'll prove if it's working.

Otherwise show screenshots of the connection errors.


I am running a print and watching from the laptop MBP but I started it on the iMac in my office. I am trying to do a time lapse. I dp not know about the version of Cura re:version but the point of this exercise is remote control. We are getting somewhere. I hear HP is teaming up with Cura to do something with scanning.

Henry Staub