IP adresses gone

What is the problem?

My IP addresses disappeared. They were at 192.168.0.xxx but switched to 192.168.1.xxx after getting new a new Spectrum modem and WiFi. IP adress was then available for a couple weeks, but now I can find it for any or my printers.

What did you already try to solve it?

Reflashing Pctoprint. Checking/changing Octoprint WPA suppliment, and 2.4g vs 5g WiFi.

Have you tried running in safe mode?

Can't figure out how to do that.

Did running in safe mode solve the problem?

Don't know.

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog... no bundle, no support, unless the reason you couldn't retrieve the bundle is your network issues


Additional information about your setup

Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ... as much data as possible


Hello @KatManDEW !

I assume a router is included.

Did this thing perform an update and/or a restart?

If you can attach a HDMI TV/monitor to the Pi (I assume you have), you get the actual IP address provided at the end of the startup sequence if a connection was established.

If you can get into the menu of the Spectrum thingy, you also should find your OctoPrint installations.

The blue words are links - you can see them on the right side of the editor window in the preview area.

Yes there is a router. I used Octoprint for 4 years before getting new cable router.

No IP addresses are provided at the end of startup.

Did you put in the new routers SSID and Password for the wifi?
You can always log in to the console with keyboard and monitor and type sudo raspi-config and enter your SSID and wifi password that way. Also make sure the wifi country code is set to your country or you wont get a wifi connection either

Thank you for the help.

It's the same SSID and Password as the old router. Both printer Raspberrys worked for about a month with the new router, but both of them disappeared from the network yesterday. I used one of them regularly for a month with the new router.

Both Raspberrys are visible in my WiFi list if I boot them with the Raspberrian OS, and I can connect to them with Putty or WinSCP.

I have spent most of the last two evenings trying to figure out what is wrong.

Hook a monitor and keyboard to your pi.
After boot up, with a prompt type in the following:

hostname -I {enter}
this will give you your IP address.

Turns out my new router supplied by the cable company does not have separate 2.5G and 5G, and my Raspberry Pi 4's running Octoprint will only connect to the 2.4G. I purchased a dual band router and it's all working now.

1 Like

Nice! Thanks for the update.
Happy holidays.