Is my Pi broken?

What is the problem?

I recently submitted a topic to this forum here:Pi 4B doesn't connect to internet - #2 by Charlie_Powell

I thought my Pi just wouldnt connect to my internet but I didn't have a way of connecting my Pi to a monitor. I now do have a way of connecting it and nothing happens except for this weird message:

[ 1.160778] raspberrypi-exp-gpio soc:firmware:gpio: Failed to get GPIO 0 config (0 ffffffff)
And this for all GPIO pins just with a different start number in brackets.

Does anyone know what this means?
Can anyone help me in any way?
I'm sorry but I'm kind of desperate at this point.

What did you already try to solve it?

I tried a different octopi image on a different SD card.

Have you tried running in safe mode?

No because I cannot enter octoprint in any way

Systeminfo Bundle

I dont have this because I cannot connect to octoprint in anyway

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

I refer to my previous post


it might be a broken sd card, get and flash a fresh card is worth to try

I already tried an older card I had and today I bought a brand new one with no succesfull result.

Have you tried to connect an HDMI TV/monitor to the Pi?
You may see what's going on.

Like I said in my post this is what happens.

hm, so there wasn't any sort of accident before the problems started? Simply occurred during a long print? And the pi isn't old? Any chances you could claim warranty?

Searching for that error brought some reports of outdated kernel modules and some hints at sd card failures. I cannot think of much more than trying a few different images to flash the new sd but if that fails again it may be a hardware problem.

yeah that doesn't look good

does the pi work besides of that gpio issue?

one thing I would try is to flash a new bootloader eeprom configuration...
I can't tell you if it can help - it's just a thing I would test if my Pi had that issue.

If you want to test it, open the pi imager, scroll down to misc utility images, flash one of those images onto an sd card (the first one is the default image), put it in your pi and let it boot. Should be done in a few seconds - if you want to be safe wait 5 minutes. Then unplug it put your old sd card back in (or flash a fresh octopi image onto the card you used for the eeprom update) and plug it in again.

If that doesn't help or you don't want to test it, you should ask the guys in the raspberry forums.
Pretty sure the pi engineers can tell you if you can do anything about it.

Thank you for your suggestion.
This sadly did also not work so I'm of to the raspberry forum.
I'll reply to this topic if I find a solution.


I have concluded that the Pi is broken. I probably shorted something out by accident.

Thank you everybody for your help.

I'm sorry to hear that but thanks for letting us know

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.