Issue getting webcam to work


#1

Hi , I have a Genius HD FaceCam 2020 and I´m trying to connect it via USB to my Prusa I3 MK3 with Raspberry Pi Zero 2. I guess it is not being recognized.
I edited the octopi.txt file, I enabled "Camera" option in raspi-config , in the lsusb command, i don´t see anything related to the camera. Now I will try running dsemg command and watch if it does recognized when i plug in the camera.
May it be a non-supported camera? Thanks a lot.


#2

Recently I connected the camera to the other USB port and for one second in Octoprint, the webcam stream showed a picture, like a photo , then the stream stopped and now it shows me this error again:

Webcam stream not loaded

It might not be configured correctly or require authentication. You can change the URL of the stream under "Settings" > "Webcam & Timelapse" > "Stream URL". If you don't have a webcam just set the URL to an empty value.


#3

Hi!

I assume, the cam runs without error with the PC?


#4

Yes, It runs perfect.

I run dmesg and it recognized the ca, i attach an image


#5

I just re-read your first post. You mentioned Raspberry Pi Zero 2?
I assume, as shown in the screen shot, it's a Raspberry Pi Zero W.
A already mentioned in other threads here, for the Zero it's hard to manage OctoPrint and a HD Webcam.


#6

Sorry , I writed it wrong. I meant Pi Zero W . I read that it´s hard to use WebCam with Pi Zero W but as i mentioned , it showed me for one second an image taken from the cam. As I looked , the cam it´s not initialized. Like the port is being disabled for some reason (it says that i have some electromagnetic interference and because of that , the usb port is disabled)