Issue resuming print after pause

Sending a print with a pause at layer to insert a nut. The print pauses but once I resume it will print one or two layers and then stop extruding filament even though the print head is moving and stats still continue to tick on printer menu. I tried unpausing the print both from the printer and from web interface and same results. I pop print file to SD card and print directly from printer and it works fine. Also tried with two different STL files and same behavior to stop extruding after unpausing. One note when i unpause from the print sent with octoprint the printer screen will still print paused on the printer screen. when i print directly from sd card and after unpausing it shows resuming print on screen.

Octoprint 1.7.3 on Pi3B
PrusaSlicer 2.4
MK3S+/MMUS2 3.10



had the same problem, think if you comment out the //#define HOST_ACTION_COMMANDS in the congig_adv in Marlin the problem should be fixed

Why is this the case? I don't understand how this solution works. Can you explain it a little more?


sure i can try.

The info comes from a setting in marlin called HOST_ACTION_COMMANDS, this converts certain commands into a visual representation in the host, in this case Octoprint and displays them.

This has also caused me problems.

If this was not the case until now, did you install a new firmware? if yes, where from?
Or have you possibly adapted the firmware yourself?

Is only a guess from me what it could be but maybe worth a try.

Translated with (free version)