Issue Updating to 1.4.0 HELP!?

I'm currently running 2 different OctoPrint 1.3.12 running on OctoPi 0.16.0 with no issues for awhile. They have been off for awhile and when I turned them on trying to update to 1.4.0 I get the below issue in the updating box.

Retrying (Retry(total=3, connect=None, read=None, redirect=None, status=None)) after connection broken by 'ReadTimeoutError("HTTPSConnectionPool(host='', port=443): Read timed out. (read timeout=15)",)': /simple/emoji/

I'm pretty novice when it comes to this stuff, i just know how to follow direction, but I'm not sure how to trouble shoot. It seems like to me its trying to connect to where ever this file is and keeps timing out?

I can install plugins and such so I dont think its an issue internet wise on my side.

I just saw the same error message when I was installing a plugin. It still worked.

1 Like

Werid, as soon as I posted this. It worked on both of my Octopi's.........fricking technology man lol

Looks like might be having issues.


What is piwheels, anyways? I'd go to their website to find out for myself, but you can see how that would go.

Python package repository. Used for pulling python software & dependencies

1 Like