Issue upgrading 1.4 to 1.5.1

What is the problem?

After upgrade to 1.5.1 I cannot get to the UI.. I can still connect with OctoPod, see camera, home, etc.. but if logging to the UI it gets stuck on "Connecting to Octoprint Server".. tried adding /recovery/ and I get "Server Error".

What did you already try to solve it?

Looked at the log, but not savy enough to understand the issue.

Have you tried running in safe mode and if so did it solve the issue?

Tied editing the config to get into Safe Mode, but see no difference. (except startOnceInSAfeMode line disappears after booting as I guess it should)

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

octoprint.log (395.0 KB)

Additional information about your setup

docker install (octoprint/octoprint:latest) running on Pi4

Did you reboot the pi? My GF's upgrade did the same thing, and when I rebooted the pi, octoprint was back and running.

This is a reoccurring issue with docker, it seems to miss updating some of the JS libraries on OP update. Strangest thing is that not only is it just the JS files, it's always jQuery UI that fails too. You can see these 'file not found' errors in your log.

Pinging @LongLiveCHIEF to take a look, and see what can be done for recovery.

No luck with rebooting... :slightly_frowning_face:

Yep I saw that but did not dare touch anything.. will probably do mode damage myself..
Thanks for taking the time to look into it, and appreciate any clues you can provide.

Just FYI... I completely messed up my installation trying to recover from backups... So I will have to manually rebuild at this point I think.
All that to say that you can close/ ignore this thread as far as I am concerned... I'm sure you have other things to work on.
Still great full for Octoprint & the community!

Stuff like this is really helpful if you open an issue on it so I can track code related to reproductions and tests of the issue.

@ertraid when you upgraded, did you do so through the UI, or by pulling a new octoprint image?

I did through the UI.. not sure if that is the right thing... was going to ask at some point.. what is the proper upgrade process on docker?
The issue is the version upgrade is "forced" on the UI along with all the plugins (which get updated almost daily)...You cannot decouple them (e.g. disable Octoprint upgrade notifications, but keep the plugins)..

Sorry for the new noobs question.. but how should I open an issue? happy to help if I can.

1 Like

YOu did it perfectly! thanks!

As for the proper upgrade process... I actually haven't created one yest because my time and efforts so far have gone into creating a docker image that supports all octoprint features in a stable way.

We do recognize that the way octoprint handles some things is counter to the ethos of docker-based applications, and I expected that upgrade are one of the areas that would cause difficulties, but I haven't had a time to do proper testing yet.

For example, issues like this, i have to determine if it happens every time, and if so, what logs I can pull from it. If it does happen every time, i have to further determine if it's an issue exclusive to docker, and usually it's not.

This one sounds like something that would actually be an octoprint bug, but I've also been making some changes to the volume mapping in the docker image, so I also want to positively rule that out as well (this is what i would look into if I can't reproduce consistently, so be prepared for me to ask you a bunch of questions about when you pulled images and what your image digests are :smirk:)

In the end, i suspect this one has nothing to do with docker, but I don't know enough to guarantee it.

You've made it easy for me though by putting details on github in a way that I can track and reproduce, as well as collaborate upstream with the maintenance team on my findings so they can investigate in parallel in case this isn't exclusively docker.