Issue with bed leveling wizard and Octoprint web interface

I'm having a issue with my second installation of an Ender 3 with Octoprint. In my first install I have no issues with using the web interface to set temp and use the bed leveling wizard. BUT on the second one I can't use any of them. The input boxes are grey or not usable. What is going on here?

I have tried using different Baudrates but no luck. At first I had a connectivity issue due to me taping over the +5v pin on the USB cable. Removed the tape and then the first printer started working again, but still the second printer can not access these command. What can I do?

Are you showing us the working printer's screenshot or the non-working one's (because I see no grayed-out buttons on this)?

If it indicates "Disconnect" on the Connection side panel widget then in theory this means that it's connected. But maybe this isn't the case since we see no temperature graph. If you're using tape on the 5V pin of the USB then remove that; it's likely what's preventing you from connecting.

Similar to what @OutsourcedGuru said. The buttons are disabled in my bed leveling wizard plugin if the printer is in any other state than operational and the user is logged in. Based on your screenshot one of those conditions is not being met.

Thank you for quick response.
Attached are 1 screenshots, this one is the "old" printer and there I can see the temperature and also change it if I need to.

The picture in the original post is the "new" printer.. no reading at all on the temp and the box is grey instead of white.

None of the printers are powered on but get 5 volt power from Pi. No tape on either cable, so the circumstances are exactly the same for both.

Den tors 11 juli 2019 18:07Sebastian Bruer skrev:

Power on the printers. You can't expect the Raspberry Pi's 5V line on the USB connector to power the printer's controller board.

Now both printers are powered on. But there is still no changes to the printers feedback. One sends me information but the other one doesn't.

If it were me, I would connect the failing Raspberry to the working printer controller board (using the working controller board's serial cable).

If it then works as expected, the formerly-failing Raspberry Pi and its OctoPrint setup would start looking like they're not the problem.

If it doesn't work, then this would suggest that the Raspberry Pi + OctoPrint are somehow different. I would then put everything back where it was. I would then move the working Raspberry's microSD card over to the non-working rig and try that. If that works then it suggests that the only thing that's different is the software and the hardware is good. At this point, I would likely then just clone the good microSD image over, rename the hostname and call it a day.

Thank you for that tip!

That will be my friday night project with a beer :grinning:

Den tors 11 juli 2019 19:35Outsourced Guru via OctoPrint Community Forum skrev: