Issue with RPi 3 and Logitech C270 Camera

i am having some major problems getting the C270 working. everywhere i look it is just a plug and play thing.

when i load the webpage it gives me the "Webcam stream not loaded" message and "http://IP/webcam/?action=stream" gives me " The webcam server is currently not running" message

i have tried a RPi 0, 2, and 3. I also tried 2 different SD cards.

I am running the latest build of octoprint.

'lsusb' shows that it sees the camera
'vcgencmd get_camera' shows supported=1 detected=0

octopi.txt is set with the following un-commented:
camera_usb_options="-r 1280x720 -f 30"

config.txt i added:

/var/log/webcamd.log shows:

/boot/octopi.txt: line 3: '\r': command not found /boot/octopi.txt: line 6: '\r': command not found
/boot/octopi.txt: line 17: '\r': command not found /boot/octopi.txt: line 25: '\r': command not found
/boot/octopi.txt: line 53: '\r': command not found /boot/octopi.txt: line 61: '\r': command not found
Starting up webcamDaemon...

--- Configuration: ----------------------------
camera: auto
usb options: -r 1280x720 -f 30
raspi options: -fps 10
http options: -w ./www-octopi^M -n

No camera detected, trying again in two minutes
No camera detected, trying again in two minutes
No camera detected, trying again in two minutes

Anyone? Please help me out.

Did you install this on a Raspberry Pi 3B using these instructions?

Is the C270 physically plugged into the Raspberry or somewhere else? If it's on the same Raspberry then the URL in theory should be just the default that was installed using the OctoPi image linked above.

Note that the IE/Edge browsers likely won't work within the OctoPrint web interface since they don't like the <img src="URL" /> approach.

Turning on webcam support in the operating system is best done using sudo raspi-config.

It seems you edited the config file with the wrong tool and corrupted line endings.
Line endings should be Unix style and it seems now it has them Windows style and the program fails to parse the file. If you edit it with windows use Notepad++. Use "Edit->Line ending conversion->Unix" and save it and should be fixed.