Issues with three instances of Octopi

What is the problem?

When I started I had 3 instances of octopi and I could connect to the first two. Then I changed the port and host and eventually got to connect to the second one. When starting the third one, I could connect but after ~20 seconds it would go offline. I changed the port and host again. After this I was no longer able to connect to the second or thrid instacne but, they stayed online for multiple hours untill I had to tuen off the raspberry pi 3B+. This is the command I to change the IP and host for the second and third:
sudo sed s/ < octoprint.service | sed s/5000/5002/ | sed s/--port=${PORT}/--port=${PORT}\ --basedir=\/home\/pi\/.octoprint2/ > octoprint2.service

sudo sed s/ < octoprint.service | sed s/5000/5003/ | sed s/--port=${PORT}/--port=${PORT}\ --basedir=\/home\/pi\/.octoprint3/ > octoprint3.service

One weird thing I noticed was If you put in The IP of the raspberry Pi (and no port) It will bring you to the page for the first instance. If you put in the IP:5000 (The port the first instance is on) It will say it refused to connect which is the error the other two give me as well.

If anyone has any Ideas It would be amazing, I've been trying to do this for a month or so and any help/ Ideas would be so so great.

What did you already try to solve it?

I.. fittled? with the Host and Port

Have you tried running in safe mode?

How do you do that without being able to access the UI?

Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!) (87.4 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

I am using raspberry pi 3B+, If anyone knows about Netowrking and such I am doing this at school so they might have something not allowing it through, I'm not sure, If anyone knew how to check that It would be amazing.

1 Like

Looks like you are changing the IP of the instances from, which you shouldn't need to do. You should only need to change the port, but unless you updated the haproxy entries, even that is unlikely to work.
If you want multi-instance OctoPrint to just work, I would recommend starting from scratch and using octoprint_deploy: GitHub - paukstelis/octoprint_deploy: Bash script for rapid deployment of multiple octoprint instance on a single machine

Thanks, I will try this. Of course, I saw this right after a meeting with the principal about the project lol. Anywho now we are waiting for someone to open the port or something. (we switched the rooms of the 3D printers) So when the district guy comes down I'll let you know if it worked.