Jobs will not start after 1.5.1 upgrade

What is the problem?

After upgrading octoprint from 1.4.x to 1.5.1, print jobs will no longer start. Octoprint runs just fine, says it is starting, but it doesn't heat up either bed or nozzle. Controls on printer control page will set target temperatures for each and they do get and hold set point, but job just sits there for over an hour before I cancel it.

What did you already try to solve it?

Rebooted Raspberry PI 3B Plus and printer and reloaded web page. Same result. Verified that I can run the print job on the printer directly (successful) and through the printers web interface (successful). Reviewed octoprint settings page (cursory as it was getting late) and didn't find obvious issues.

Have you tried running in safe mode and if so did it solve the issue?

Not at this time, but will after posting this.[octoprint.log|attachment]

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

octoprint.log (2.8 MB)
serial.log (148 Bytes)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint 1.51
OctoPi Version 0.17.0, running on Raspberry Pi 3 Model B Plus Rev 1.3
Cetus3D MkII extended running TinyFAB CPU on TinyFab main board
UCTronics 3.5" HDMI touch screen with OctoDash v2.12

browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:83.0) Gecko/20100101 Firefox/83.0
connectivity.connection_ok: true
connectivity.enabled: true true
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1400
env.hardware.ram: 970825728
env.os.bits: 32 linux
env.os.platform: linux2
env.plugins.pi_support.model: Raspberry Pi 3 Model B Plus Rev 1.3
env.plugins.pi_support.octopi_version: 0.17.0
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 19.3.1
env.python.version: 2.7.16
env.python.virtualenv: true
octoprint.safe_mode: false
octoprint.version: 1.5.1

Install the OctoLapse update, then try again. (0.4.1, you have 0.4.0)

1 Like

Thanks Charlie. I'll do that. I THOUGHT I had updated all the plugins.

As an update, I just restarted it in safe mode and started the print job. It looks like it is working (bed is now heating up to temp like it should).

I'll report back if it starts printing from safe mode and after updating the plugin.

In safe mode, the printer warmed everything up and then started. I'm going to let the job finish (3 hours or so) and then see if updating the plugins fixes it in regular mode.

It'll be OctoLapse, there were compatibility issues addressed, and I've been reading of these problems all week. Safe mode definitely confirms it is a plugin issue, 99% sure you will be fine after the update to 0.4.1.

That was indeed the problem. Thanks for the VERY fast help on this!

1 Like