Just installed OctoPi - printing in the air

I have just installed OctoPi some days ago and everything seems to work so well. I'm very impressed until my printer starts to print a print job (transferred from Pi and printed from SD-card - started from OctoPi).

I have sliced my gcode-file in Cura 4.0 and exported and uploaded the file to OctoPi. Shouldn't this be OK or do I need to setup right printer settings-profile in OctoPi. s I'm running Cura 4.0 I'm not able to import the profiles-file into OctoPi so I skipped it and thought that when Cure 4.0 had made the slicing it should be OK for the OctoPi to print it. But I could be wrong.

What happens: The printer starts out fine (though with double auto leveling - before and after heating up). Then the printing starts and it seems fine for the first couple of layers but then the nozzle starts to print in the air somehow like the Z is going crazy and no filament is extruded.

Octo Print Version 1.3.11
OctoPi Version 0.16.0, running on Raspberry Pi 3 Model B Rev 1.2
Using Creative Live Cam Sync HD

Like I said everything has been so easy with the connecting of the printer and webcam and the plugins with BL-touch etc. But the printing quality halts a lot.

For the double leveling: I guess something in your start g-code is off. Check your cura printer profile maybe there are two G28/G29 commands?

For the air printing:
Did the extruder stop to turn? Just to be sure that the nozzle isn't clogged or that the extruder looses its grip to the filament.
Does the print work if you just copy the gcode file from your pc on your sd card and if you print from sd card without octoprint at all? So we can check if the error is on the octoprint side or somewhere else.
If the gcode without octoprint works I would try to run octoprint in safe mode. Maybe a plugin causes this problems.

1 Like

Oh I'm so grateful - thanks for your advice it is highly appreciated.

I have now started troubleshooting as you suggested. Setting OctoPrint into safe mode and trying to print from my SD card. It seems to be some kind of problem with my left extruder (I'm having a dual color/single nozzle Greeetech A20M printer) - where left extruder is black and right extruder is white.

My Troubleshooting:
I have now downloaded a color-cone for test printing. Then I have tried to print a white one (right extruder) with success but when I print a black one ( left extruder) it starts to print in the air as the extrusion is not working or the printer has got a command to somehow stop printing. So It might not be OctoPrint making my problems. Though I have tried to simulate a filament change for black color and then command for further extrusion and here the black filament come out fine. So what can I now do to improve my left extrusion??

Well I have made yet another test. Choosing to print my white cone file with opposite color (a setting I can chose on my printer) and then a black cone was printed successfully. So it must be something in my Cura 4.0 slicing that makes this left extruder behavior. But whar can it be? Can I somehow compare gcode-files to see where the difference is?

You can use the diff command on linux systems (such as the raspberry pi) in order to compare text files, run diff ~/.octoprint/uploads/FILENAMEHERE.gcode ~/.octoprint/uploads/OTHERFILENAMEHERE.gcode | less and use your enter or arrow keys to scroll down the output.

There is also a diff on windows if you prefer it: FC File1 File2 in cmd.

I personally prefer this page
http://www.qualidator.com/WQM/en/Tools/TextDiff.aspx

For me it's better to work with than console output.

@TheGreatBorg
Also I saw this .
It might not be your problem but I guess he has a similar thing. Check your config if you set everything for dual extruder. Maybe you left something in the wrong setting :slight_smile:

The only problem with web tools is if the gcode file is large then copy-pasting it in can be a hassle in terms of RAM usage

1 Like

true

I never used it for something like this :smiley: