Just upgraded my Octoprint to 0.18 but now it cant find the serial output

What is the problem?

I upgraded octoprint so i can be on python 3. Restored from backup. When I reboot the pi it connects and I start a print and then it says "Closing serial port due to emergency stop M112". Everything was fine an hour ago on octopi 0.17, then I reflashed my sd card to get the new update and it wont connect. After that initial error. when I try to reconnect it says this "No more candidates to test, and no working port/baudrate combination detected." While I'm trying to fix this it also keeps randomly haulting my printer.

Update: I turn the printer on and off and it connects, I try to print something from octoprint and it haults the printer

Can the issue be something related to the marlin software I have on my ender 3? It was fine for octopi 0.17

What did you already try to solve it?

New cables, rebooting on both ender 3 and the pi

Have you tried running in safe mode?

yes

Did running in safe mode solve the problem?

no

Systeminfo Bundle

You can downoctoprint-systeminfo-20211020210303.zip (130.6 KB)
load this in OctoPrint's System Information dialog ... no bundle, no support!)

INCLUDED

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Ender 3 Pro
Version 1.7.0
Version 0.18.0, running on Raspberry Pi 3 Model B Plus Rev 1.3
Marlin V1.3.1

Nothing works and there's nothing we can do without the information asked for in the rest of the template you deleted. Hint: Each blue text in the template is a link to instructions on how to provide that piece of information.

1 Like

Apologies, will fill out again

This isn't a mainline Marlin version - is it a fork? Or Creality's 'Marlin' firmware?

The 'thermal runaway' plugin has been causing the M112 errors a lot, as there's some strange logic in there somewhere. Disabling this plugin should stop those errors.

When the printer is halted with M112, it must be turned off and on again, this is a safety feature - the thermal runaway plugin is trying to shut it down it seems.

I dont know where I downloaded it but I thought it was legit. pretty sure I got it off their website. I disabled the plug in and it works now. THANK YOU. Do you know why it would of done this now but an hour ago I never got that error?

By disabling that does it mean I don't have thermal runaway protection anymore?

Thermal runaway protection should always be built in to the printer. Plugins in OctoPrint are not a good enough solution to the problem anyway.

Creality's version of Marlin is made with added bugs, however it does have TR protection enabled.

You can test this yourself, by unplugging the heater to simulate a fault with it.

1 Like

thank you for making my day with the solution

1 Like