KILLED Printer Halted Please Reset Ender 3 Pro BLTouch HELP

So, the notorious BLT...

I managed to install and it was running perfect, printed a few files flawlessly until...it started to give all kinds of errors. Tried everything I could find online. If I keep on re-doing everything eventually I can get it to print once, then I start getting errors before the print starts.

Issues:

  • Probe starts blinking during bed leveling prior to printing
  • Sometimes will not stop on Z axis and hit the bed
  • LCD Killed Printer halted please reset error
  • LCD Homing error please reset (something like this)

The thing that I cant understand is how can it go from working to not working by itself?? I mean, you either did it right or wrong, so it works or it doesnt. All the posts I read were people trying to get it to work for the first time. I mean, if the cables were wrong it wouldnt work, if the firmware was wrong it wouldnt work.

What is the problem?

Wont finish probing without error before printing.

What did you already try to solve it?

Checked the wires 300 times, re-did the connections, soldered, heat shrunk and hot-glued. Re-installed the firmware a dozen of times. Ran with/without SDcard. Switched USB cable.

Have you tried running in safe mode?

No.

Systeminfo Bundle

browser.user_agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/14.1.1 Safari/605.1.15
connectivity.connection_check: 1.1.1.1:53
connectivity.connection_ok: true
connectivity.enabled: true
connectivity.online: true
connectivity.resolution_check: octoprint.org
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1500
env.hardware.ram: 1903988736
env.os.bits: 32
env.os.id: linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 4 Model B Rev 1.2
env.plugins.pi_support.octopi_version: 0.18.0
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 20.3.3
env.python.version: 3.7.3
env.python.virtualenv: true
octoprint.safe_mode: false
octoprint.version: 1.6.1
systeminfo.generator: systemapi

Terminal:

Recv: echo:busy: processing
Recv: TT::245.00245.00 //245.00245.00 BB::100.00100.00 //100.00100.00 @@::9191 BB@@::7777
Recv:
Recv: echo:busy: processing
Recv: Error:Probing Failed
Changing monitoring state from "Printing" to "Error"
Send: M112
Send: N11 M11217
Send: N12 M104 T0 S0
18
Send: N13 M140 S087
Changing monitoring state from "Error" to "Offline after error"
Connection closed, closing down monitor
Changing monitoring state from "Offline" to "Opening serial connection"
Connecting to port /dev/ttyUSB0, baudrate 115200
Changing monitoring state from "Opening serial connection" to "Connecting"
Connected to: Serial<id=0xab530d30, open=True>(port='/dev/ttyUSB0', baudrate=115200, bytesize=8, parity='N', stopbits=1, timeout=10.0, xonxoff=False, rtscts=False, dsrdtr=False), starting monitor
Send: N0 M110 N0
125
No answer from the printer within the connection timeout, trying another hello
Send: N0 M110 N0*125
There was a timeout while trying to connect to the printer
Changing monitoring state from "Connecting" to "Offline"
Connection closed, closing down monitor

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint Version 1.6.1
Ender 3 Pro
Mainboard 4.2.2
Firmware Ender-3 Pro- Marlin2.0.1 - V1.1.2 - BLTouch.bin (downloaded from creality)
BLTouch ANTCLABS V3.1 from creality
Check pics for cable setup:




Let me know if I can give you any other information.

Please help, I use this printer for work. Thank you very much.

Please share the complete Systeminfo Bundle file

I've seen similar things, probe blinking, the messages about an error asking me to reset etc. Tried all sort of things (but much less than you did)

It turned out to be a stupid mechanical problem at the probe, I never even saw it but taking the metal finger of the probe and push it up/down/up/down a few times, with no force, just playing it easily: that solved it for me. Perhaps a little spot of dust or simply adhesion, I don't know.

Now, I don't have a genuine blTouch but a GeeTech clone so this may or may not help. But worth a try

Let me know if you need anything else.

Thanks!

octoprint-systeminfo-20210623180522.zip (828.9 KB)

This is deferentially an error from the printer.

Have you tried the BLTouch test mode yet? The firmware should have one

No, is that what SW mode is? Should I try to print with it enabled?

With my printer it's

Configuration -> BLTouch ->BLTouch self test

Ok, it goes up and down repeatedly.

So it is working.
For you have a Creality printer, try with or without SD card in the printer.

Yes it works, but it stops working by itself before printing starts. Everything seems right, it auto-homes, but when its bed leveling before the print it will start blinking give an error message and stop in one of the 9 bed-levelings. Then I have to remove the usb cable, restart the printer, restart octoprint, connect again and start all over. Everything seems fine until it stops again while bed leveling. Maybe I got a bad bltouch unit?

Then check if the bed is even and clear.
If you have a removable print surface, then check underneath.
If the difference in the measurements is too great, you also get that error.

If there was information out there people wouldnt have to ask for help, available information is limited to user experience and when something different happens theres no explanation anywhere. Information is scattered all over and you never know where the source of your answer might come from. But now I have information to share about this whenever it happens to someone else, and thats the beauty of the internet! I'm sure this has happened and will happen to others and I hope they can find this post.
So, what happened was that the BLTouch I got was for the 1.1.2 mainboard and I re-wired the connections for my 4.2.2 mainboard. Shouldn't be a problem, even because it worked on several occasions. Intermittent failure is beyond my comprehension. Therefore, it could only be a result of a bad physical connection. Thats why I made sure it wasnt the case by glueing/soldering. But it still happened. So my second opinion is probably the case, it was a faulty unit, something wrong with the unit itself. That would be my best guess.
I returned the unit and got a new BLTouch for the 4.2.2 board and have just installed it, seems to work fine so far.
As far as a clone goes, I had the same printer with the 1.1.2 board and I installed a 3DTouch unit instead of the BLTouch and it did not work properly after I spent days trying. So much I sold everything and got a newer Ender 3 Pro with the 4.2.2 board and another BLTouch for the 4.2.2 just like the one I have now.
Thank you all (Ewald_Ikemann) for contributing.

3 Likes

It's the firmware

I had the same error until i found a thread here with a someone who made a custom firmware for the ender 3, it is a special case of octoprint not playing nicely with a bltouch connected to an ender 3, it disables the 5v probing or so on

I would link it now but I'm on phone currently^^ will do as soon as I can or you can look Abit further here in the forums, there is a thread with the same problem and a firmware download that fixes everything

there is the firmware that makes it work
it really is just an edge case of bltouch with ender 3 and octoprint

I hate to say it but I’ve had very bad luck with genuine BLTouch. Every one I’ve had has failed and in a similar way. I started using the triangle labs 3D Touch clone and have found them to be MUCH more reliable. I have a box with 4 BLTouches that behaved so strangely I just swapped them for 3D Touch by Triangle labs and forgot about it. I’m talking versions I bought direct and ones that came with my printers. I hope you figure it out, but if not try a clone by Triangle Labs.

You know that there are fake BLTouch on the market?

I don't think that Antclabs want ruin their reputation by selling bad stuff

Just relaying my experience. I have every confidence that the 4 BLTouch probes sitting in my junk box are genuine.

I recently experienced something that might relate. After initiating the automatic mesh probe process from Octoprint:
the bed moved to the correct location for the first measurement
the sensor measured the first point
the print head moved to the second location
the bltouch started blinking and the process stopped
Octoprint disconnected from the printer because the firmware reported an error

I did a bit of troubleshooting and found that somehow the printer bed had moved up. The mesh leveling process was not able to continue because the error was too great. I leveled the bed manually using the usual process with a piece of paper. After that automatic mesh leveling worked fine.

Hope this helps.

Have you checked for the QR code?
Also sometimes the firmware can be faulty too.

It may be something as simple as the bed being obstructed by the one of the uprights