Lag issues with webcam over the Internet


#1

What is the problem?

Extremely Slow Video stream from webcam over the internet. about 30 seconds.

What did you already try to solve it?

I have done quite a bit of reading on topics here and on other forums, but none seem to be talking about lag issues while accessing the octoprint instance form the outside

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)

Latest Octoprint image, basic authentication into Octoprint GUI, Logitech C270, RPi3B+ on WiFi, CR-10 Stock firmware

My question here is, would webcam speed (latency?) benefit from a Ethernet connection instead of WiFi even if I am 30+ ft away from the modem/router? Does the Ethernet cable length matter? at what point would it matter? Ask me questions if more info is needed (I'm sure it is), I am not sure what kind of extra info is needed here.


#2

What is the speed of the internet to your house? Some providers have extremely slow upload speed in their packages, and upload speed is where the feed would be coming from. Do a speed test from your house.


#3

Thanks for the reply, I think that is a majority of the issue... Upload on Wifi is 0.04 Mb/s and Download is 0.29 Mb/s.. WTH? This is for a set up I am doing at a friend's business.. That is terrible connectivity. My home internet is 100 times faster than this. I'm surprised it even shows me a picture.


#4

Wow. That is insanely slow.
Try it with Ethernet if you are near to the router and see what that does...


#5

Okay, I will. I will have to get a 30+ft Ethernet cable.


#6

seems that the Ethernet connection is actually slower than the WIFI connection. I'm not sure how that could be... tried on a laptop, speed test would test (slowly) on WIFI, but test would time out on Ethernet. that's crazy to me. Any thoughts?