Latest Marlin2.0-bugfix with TMC2208 UART control makes Octoprint unstable


#1

What is the problem?

Just like the title says;
I've installed the latest Marlin 2.0 bugfix release and use Trinamic TMC2208 stepper drivers witch are controlled via a UART connection.

This makes Octoprint unstable. I had to disable the "EEPROM Marlin editor" plugin to get Octoprint to work at all but still somtimes I have a strange issue.

The issue is that Octoprint receives serial data just fine but it can't send any.

With the plugin disabled Octoprint is mostly usable but a M500 imediate blocks the serial connection.

What did you already try to solve it?

  • I used google (and found nothing)
  • I switched Pi's (Used the Pi from a different printer) with the same result
  • Connected the printer to my PC and used a serial console witch worked fine

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)

OctoPrint version:
Version 1.3.10

OctopPi version:
Version 0.15.1

Firmware version:
Most recent Marlin 2.0-bugfix