Layer shifting only when using OctoPrint

What is the problem?

I have been printing every day since I received my printer about 3 weeks ago and I have not had a single layer shift.

I decided to jump in and add an Octoprint to my Ender 3 Pro. I was able to get it working without issue and the software seems to function exactly as it should.

The issue is that if I upload a gocode file to the PI using Octoprint, I get layer shifting at the same height, but the direction of the shift is not the same. If I load the same exact gcode file onto an SD card in the computer and then install in the printer, the print comes out perfect. I have done this multiple times with the same result.

Weeks of good prints with SD card... failed prints with gcode sent to PI using Octoprint with layer shifts at the same height... switch back to the cheap Chinese SD card and its back to working fine.

Does anyone have any idea of what I might have done/setup/configured incorrectly?

What did you already try to solve it?

Left to right. Octoprint to PI 1st attempt, Octoprint to PI 2nd attempt, back to the old SD card method (take out of printer, save gcode using computer, install back into printer)

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)

Ender 3 Pro
Slic3r 1.41.3
Raspberry PI3B+ (Purchased from Adafruit along with recommended power supply)
Octopi 0.16.0 flashed on to Kingston 8GB Industrial SD with speed rating of 10 using Etcher

I am not sure if it is relevant, but I noticed that when I send this particular gcode from the computer to Octoprint, I get an estimated print time of 2.5 hours. If I save the same exact gcode manually to an SD card, Octoprint shows a print time of just over 3 hours. Not sure why the same gcode file would show different print times depending on how it was transferred.

Any help would be much appreciated. I know that thousands of people use this software without issue, so it must be something on my end. I can say for sure though that I can โ€˜turn the issue on/offโ€™ by using the SD card or uploading to Octoprint. This fact should allow me to eliminate any hardware issues (belts, steppers, binding, etc) from my troubleshooting.

Hi, did you solve?
I have the same problem!

I have a GEEETECH E180 and to get my printed parts correctly I used the official slicer and software to control the printer (EasyPrint) and magically it starts to print correctly!
The same file, same gcode (exported from official software) dropped on octoprint jups around the plate misaligning every time!

I tried, raspberry 1, 3 and new power supply (as suggested) with no luck
Luckly for me i can review immediately as it start shifting layers on 3rd/4th layer after start

Do you have some logs? The serial.log would be quite handy...

1 Like

Here it is (34.1 KB)
I tried everything...i hope you find something to suggest me

Sorry, but there is nothing useful in the serial log:

2019-11-07 10:24:38,636 - serial.log is currently not enabled, you can enable it via Settings > Serial Connection > Log communication to serial.log
2019-11-07 11:56:18,235 - serial.log is currently not enabled, you can enable it via Settings > Serial Connection > Log communication to serial.log
2019-11-07 15:37:17,373 - serial.log is currently not enabled, you can enable it via Settings > Serial Connection > Log communication to serial.log
2019-11-07 15:41:43,494 - serial.log is currently not enabled, you can enable it via Settings > Serial Connection > Log communication to serial.log

I guess we're supposed to read the log, huh?

1 Like

enabled the log and added the gcode for comparison (214.5 KB)

PS: every run the new shift position is random, in this log it's on the left of the center (the right print position), before was up

You can try increasing your serial connection timeouts x4. I don't remember what it did to my prints but I had to do that a long time ago.

Do you think it's sending some timeouts? Should i disable it?

I am also experiencing layer shifts. I used to print with my Raspberry pi 3 for many years, first with a Lorei printer, then with my Tenlog D3. I have made an update of my logic board and since then my printing almost always fail due to layer shifts. The very same gcode file printed from my SD never fail. I thought, OK, there must be something wrong with my raspberry SD card and/or my raspberry and/or my OS. I setup a new Raspberry 4 from scratch with a HQ SD card and the 'official' octoprint distribution. Nothing else is installed on this new raspberry. Unfortunately, I have the very same issue. Something is wrong but I do not know what. @fabiosoft: did you try to increase the serial connection timeouts? Did it solve your problems? Attached are 2 photos of the same file printed from Octoprint and from internal SD card...

Hello @Antonino_Nicoletti!

Can you share the LOGS?

I am also having very similar issues as everyone else. Prints turn out just fine on SD card but has layer shifting when printing through Ocotprint. I've had Octoprint on my browser lag out and become unresponsive during some prints that had layer shift but I also have have some prints fail without having any issues on my browser. My pi is powered by a good enough power supply and my Pi is connected via ethernet to my computer so I would think the connection is good. Attached are 2 logs from 2 failed prints.octoprint.log (24.9 KB) octoprint2019-12-05.log (33.8 KB)

Here is the log of the failed printed object in the last post picture :

Hallo! from the first glance of the octoprint.log s you provided, you have different issues concerning the layer shifts.

Please: Both of you open a new thread and please answer all queries that a given in the template.

1 Like

we'll do it as @Ewald_Ikemann said. I'm closing this thread for now.

1 Like