Lean on prints develop from raspberry pi sitting for a while

I have an issue where I will start a print on the Ender 3 pro via octoprint (running on a raspberry pi 3 B+) and the print will have a heavy lean in both the x and y axis. I did all the normal tweaking of my x and y belts and there are no issues. I discovered that if I reboot the pi, it solves the issue for probably a day or so, then it reoccurs.

The Ender 3 pro is stock except for using a Bigtree skr mini main board, BLTouch and running Marlin 2.0 bugfix compiled. Raspberry pi is stock and the software is installed via the approach dictated on the octoprint website. Seemingly this is coming from the octoprint software, or the raspberry pi itself.

I am ok with rebooting the pi, but is there a better solution to this?

So not stock at all :stuck_out_tongue:
I think it would help if you upload a picture of a leaning print

New user so I can only post one photo.

Meant stock in the motors, drive wheels, rollers etc. :slight_smile:

Sure, here is a CHEP cube with the issue.

I printed several leaning ones while adjust belts to no resolution for the issue. I rebooted the pi and then things print fine for a couple days.

This morning a print started doing it again (notice the layers shifting towards a lean).

I rebooted the pi and printed a perfect-ish cube.

Honestly, I would feel like this was a belt/drive/motor issue, but the pi reboot resolves it every time thus far.

Here is one right after pi reboot.

Wow what a difference.

I would try it in safe mode. Maybe a plugin causes that issue after some time.

I will give that a try next time before I do a reboot to see if it is the root cause. Unless it makes me do a reboot... hahaha. Also, maybe I will do a octopi restart instead of the whole pi, see if it is localized to the process.

Hi @jsauter,
what plugins do you use?

  • Action Command Prompt
  • Bed Visualizer
  • GcodeEditor
  • Octolapse
  • Octoslack

That's layer slip.
Reinstall Octoprint using the OctoPi image, I had problems with layer slipping from another plug-in. Disable all the plug-ins. Then try again.
If rebooting the Pi cures it, have you replaced the Pi?
What are the settings in your slicer and does that match the printer?.
I have a Pi and an Ender 3 Pro with an SKRminiE3 and it doesn't do that - but I do have 'stock' SKR firmware loaded off BTT's Github, without BL-touch.

I have another pi for my other printer, I can probably try swapping them if this becomes a continuing issue.