Lidl LED Stripe control | Livarno Home LED Band digital

Hello all,

I found the following LED strips at home:

I have the problem that I just can not figure out how to get the LED strip controlled via Octopi.

Ideally, without the IR controller / remote control that is included.

I have already searched a lot to find out which controller is installed or which LEDs have been used here, but any online search has so far been unsuccessful.

Now I'm hoping that someone here may have faced the same problem or may even have a solution ready.

The LED strip has 4 connectors. VCC (24V), 2x GND and once DI

I have already tried to get something to light up using the WS281x LED Status plugin and GPIO pin 15 and selecting any available LED type, but to no avail.
I disconnected the supplied power supply of the LED strip and connected it to a piece of the LED strip (rear piece without IR controller etc.). I connected the GPIO pin 15 with the DI of the strip. Then I connected the GND of the power supply with the GND of the strip and the Raspberry Pi.

Maybe someone can help me. Would be great
Kind Regards

OctoPrint version 1.7.3, OctoPi version 0.18.0, printer Ender 3 V2

they don't mention the type of led and controller on that page but from the IR-Remote I guess it is a GRB 4 cable connection. I doubt you can hook it up with the IR - based controller but a d1 mini or similar mcu with tasmota firmware should do and you can MQTT to control it then.

1 Like

I have now figured it out - today had a little more time over :slight_smile:
Took an ESP32 and worked with the FastLED library. They are the WS2811 and thus also super controllable.

Perhaps for future, looking quite interesting - since the LED strips from Lidl are really very cheap.

If they are WS2811 then they should work with the WS281x LED Status plugin for OctoPrint.

I noticed in your post you mentioned using GPIO 15 - the plugin uses GPIO 10 for SPI, other options don't work easily.

1 Like


Great information !
I got one of those a couple years ago, and the controller IC has no markings !
Been using some of the RGB LEDS after desoldering them...

1 Like

Had changed the GPIO PIN, because I thought it might be the default PIN :P. Do not load it. In addition to the unknown controller, I had for whatever reason turned off the SPI in the Raspberry Pi.

Now everything runs wonderfully.
In WS281X LED Status it is the type: WS2811_STRIP_BRG

1 Like