LifeCam VX-3000 Octoprint


#1

I am trying to connect an old USB "LifeCam VX-3000" camera to my Raspberry Pi 3,2,

I have updated /root/bin/webcamd to have:
camera_usb_options="-r 640x480 -f 10 -y"

But I still get This error in the /var/log/webcamd.log Log:

logger: Starting USB webcam
Running ./mjpg_streamer -o output_http.so -w ./www-octopi -n -i input_uvc.so -r VGA -f 10
MJPG Streamer Version.: 2.0
i: Using V4L2 device.: /dev/video0
i: Desired Resolution: 640 x 480
i: Frames Per Second.: 10
i: Format............: JPEG
i: TV-Norm...........: DEFAULT
i: Could not obtain the requested pixelformat: MJPG , driver gave us: JPEG
... will try to handle this by checking against supported formats.
Init v4L2 failed !! exit fatal
i: init_VideoIn failed

Here is my Camera:

pi@Octopi-CR10:~ $ lsusb
Bus 001 Device 004: ID 045e:00f5 Microsoft Corp. LifeCam VX-3000
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

What else can I try?


#2

Ive had similar issues with life-cams and mjpg_streamer tho my octoprint is on a box running MX16 which is a debian-based so should be similiar.
first just make sure your webcam is actually at /dev/video0 by running

ls /dev/video0

so long it is there than you can
check for uvcvideo

modprobe uvcvideo

so long it is there than you can try to

sudo service webcamd restart

and if still nothing good happening. you can attempt to manually start mjpg from the prompt by issuing the command yourself and this is where with a lil patience you can get it to work most the time. start by changing the flags a bit each time you reissue the command. (using up arrow to make it quicker)

  • ./mjpg_streamer -o output_http.so -w ./www-octopi -i input_uvc.so -r VGA -f 1

  • ./mjpg_streamer -o output_http.so -w ./www-octopi -i input_uvc.so -y -f 10

  • ./mjpg_streamer -o output_http.so -w ./www-octopi -i input_uvc.so -y -f1

You can notice subtle changes to each command if one of those commands works you can <ctrl> + <c> too kill it and than make the changes too the webcamd config file accordingly.

for instance my lifecam 1000 runs well with this command

./mjpg_streamer -i input_uvc.so -d /dev/video0 -y -f 5 -o output_http.so -p 5001 <-w ./www-octopi>

However if NONE those work than you may want to double-check your webcamd config file and make sure all permissions on files and folders are correct and check this out:
https://groups.google.com/forum/#!topic/octoprint/yejwBvmpSfs

and basically someone might be able to pinpoint your issue quickly because of some luck but mjpg_streamer in my opinion it was quicker for me to solve my camera issues by running the command mutiple times with different flags until one worked and than i made the changes too the webcamd config file accordingly.