Login via haproxy not working. via :5000 works

What is the problem?
The login via haproxy is always rejected.
What did you already try to solve it?
Tried login in via the url with port 5000. That works.
Tried rebooting the pi.
Logs (octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support!)

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible)

Octopi on raspberry pi 4. Configured to run 2 instances. If connecting to port 5000 or 5001 I get a login and am able to login. When I use the /a10/ path I also get the same login but it does not work.

I tried enabling http authentication on haproxy. That only adds a http login but when logging in it still stops at the regular login.

Ok. Worked it out. It was the first rule to filter the /printername/ that was not correct. Now it works.

The only issue still is the udev not working for ttyUSB0
/dev/ttyPrinter1 -> ttyUSB0
/dev/ttyPrinter2 -> ttyUSB1
However in the dropdown it shows
But not the ttyPrinter1 that I would like to see.
Tried putting that in the config.yaml but still doesn't show in webgui.