Logitech Quickcam Web / Lego Camera

Camera model
ID 046d:0850 Logitech, Inc. QuickCam Web

What is the problem?
Camera does not seem to be connecting, or showing up

What did you already try to solve it?
I edited octopi.txt by adding -y

camera_usb_options="-r 640x480 -f 10 -y"

and rebooted with the camera attached with no luck.

Logs (/var/log/webcamd.log, syslog, dmesg, ... no logs, no support)

tpi@octopi:~ $ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 046d:0850 Logitech, Inc. QuickCam Web
Bus 001 Device 003: ID 2b71:0002  
Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub




--- Configuration: ----------------------------
cfg_file:      /boot/octopi.txt
camera:        auto
usb options:   -r 640x480 -f 10 -y
raspi options: -fps 10
http options:  -w ./www-octopi -n --listen 127.0.0.1

Explicitly USB device:
-----------------------------------------------

Found video devices:
/dev/video0
/dev/video10
/dev/video11
/dev/video12
/dev/video13
/dev/video14
/dev/video15
/dev/video16
config file='/boot/octopi.txt':USB device was not set in options, start MJPG-streamer with the first found $
<13>Dec 30 06:07:49 root: Starting USB webcam
Checking for VL805 (Raspberry Pi 4)...
  - It seems that you don't have VL805 (Raspberry Pi 4).
    There should be no problems with USB (a.k.a. select() timeout)
Running ./mjpg_streamer -o output_http.so -w ./www-octopi -n --listen 127.0.0.1 -i input_uvc.so -r 640x480 $
MJPG Streamer Version: git rev: 85f89a8c321e799fabb1693c5d133f3fb48ee748
 i: Using V4L2 device.: /dev/video0
 i: Desired Resolution: 640 x 480
 i: Frames Per Second.: 10
 i: Format............: YUYV
 i: JPEG Quality......: 80
 i: TV-Norm...........: DEFAULT
 i: The specified resolution is unavailable, using: width 356 height 292 instead
 i: Could not obtain the requested pixelformat: YUYV , driver gave us: GRBG
    ... will try to handle this by checking against supported formats.
Init v4L2 failed !! exit fatal
 i: init_VideoIn failed
Done bring up all configured video device

Goodbye...

Additional information about your setup (OctoPrint version, OctoPi version, ...)

Octopi is a fresh install of 0.18.0

any help would be greatly appreciated

Try -u instead of -y
Not sure whether it helps or not but it's worth a try

I can try it out, what does -u signify?

I'm not sure. Found it here