Logitech Unifying Receiver Install on Raspberry Pi 4 running Octopi

Using the Logitech Unifying Receiver on a Raspberry Pi requires the use of a program called Solaar.

What is the problem?

Logitech M720 not recognized by Solaar & Paired devices are not displayed

What did you already try to solve it?

Tried installing Solaar multiple times, both via command line and via the optional GUI

Have you tried running in safe mode?

RPI boots OK, problem is with Solaar install

Did running in safe mode solve the problem?


Systeminfo Bundle

octoprint-systeminfo-20240705172330 (1).zip (2.0 MB)

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


Additional information about your setup

What kind of hardware precisely, OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint version 1.10.1, Octopi version 1.0, solaar version 1.1.13, M720 mouse (won't pair), Anywhere MX mouse pairs but not displayed

Tell me if I'm being stupid & getting this very wrong (probably), but you are trying to install a wireless mouse to the RaspberryPi ??

If so have you plugged in the "unifying receiver", which I take it is also for the associated keyboard (K780), and does the Pi recognise the device the devices, which I find usually just work !!

Yes, I am trying to pair the M720 mouse to a raspberry pi, and yes, a unifying receiver is plugged into the Pi. As there is no Logitech software for Linux based systems, you have to use a piece of software called Solaar (found on git hub), which virtually every tutorial on this subjects says to use. I have successfully installed Solaar on the Pi, and can get the software to start, but it will not recognize and pair with the M720, the box where the paired devices are shown is simply blank. Further, I have another Logitech mouse which did pair with Solaar (i.e. the cursor is controlled OK by that mouse), but Solaar does not show it as paired, again a blank screen.

The M720 mouse has a built in switch that allows you to switch between three different devices. The M720 pairs and works fine on my WIndows 10 PC, so the M720 is working as specified. The problem is with the Solaar software. My goal is to have the other two switch selections pair with two raspberry pi's that are running Octopi.

I believe the Solaar software comes from this site, and the problem you are having is almost certianly not OctoPi specific. I suggest you open an issue on that github page. Provide the contents of /etc/os-release which will identify OctoPi's underlying operating system along with as much other detail about your configuration as possible.

I may be missing something, but usually I pair my Logitech receivers with a mouse and keyboard, on a Windows PC using the Logitech software.

Then I can plug in the same receiver into the Pi running Octopi, and it just works.

Can you not do the same?