Logitech Webcam c922 change Hz

Hi I'm just setup my webcam Logitech C922 for my MK3S with 1280x720 30 fps. It is working realy well but the lightning in the room is 50hz and the camera shows 60hz with flickering. Is there a start command that changes the 60hz to 50hz anywhere?

Rest is fine and works like it should.



Are you using octopi?
If yes you can edit your octopi.txt (it's on the boot partition of your sd card and can be edited on a pc if you want).

### Additional options to supply to MJPG Streamer for the USB camera
# See https://faq.octoprint.org/mjpg-streamer-config for available options
# Defaults to a resolution of 640x480 px and a framerate of 10 fps
#camera_usb_options="-r 640x480 -f 10"

Thank you for your response. I already edited with the 1280x720 and 30 fps. But now I need to set the 50hz for eu instead the standard 60 for us. Can you help me on this?

Just change it to 25 fps :slight_smile:
If you still get flickering it's because of the shutter speed. I'm not sure if it can be changed with this setup.

25 FPS works for the app octopod but not for the Webinterface. I am actual recording a timelaps. Will report how good it will look.

Of course, that won't help you but at least you know that you're not the only one hating life.

You might try changing the fps from 30 fps (what it is now) to...

30 * (50 / 60) = 25 fps

...as suggested (in theory, at least).

So now, if that doesn't work, you might try dialing it down by 1 until it looks the best.

FYI, your flickering issue might also come from LED lights. The 50/60HZ correction (as far as I know) only corrects for some old school fluorescent ballasts that operate at mains frequency. I was just reading that incandescent might have flicker too, since they get hotter as the amplitude increases, but I have never seen this personally, but don't doubt it can happen.

Some LEDs use pulse width modulation to control the brightness (dimmer switch), or to prevent burnout (lower heat production) while over-driving the LED. My cheapo LED lights I had in my enclosure caused flicker even with the flicker reduction settings (50/60HZ) enabled. Eventually I tracked it down to the LEDs themselves, since halogen lamps and incandescent showed no visible flicker whatsoever.

It is a pain in the butt to figure out what frequency any particular LED's PWM operates on, but something on the order of 5KHZ+ should work fine. I eventually found some LEDs that operate at many KHZ, and I now have zero flicker. I went through 3 other LED panels before I found one that worked, so buyer beware.

Interesting read on fps and the human eye/brain.