Lose connection to web interface


#1

Octoprint appeared to be running fine with no issues. While in the middle of a print I stupidly went and changed a setting and pressed save. As soon as I hit save the print stopped and it appeared as though Octopi was trying to pause the print. I was not able to restart the print or get the interface to respond. I power reset the Pi and was still not able to get back into the web interface. I was able to ping the Pi and connect via SSH without issue.

I then reflashed the SD card with Octopi again and went through the setup. As I was reinstalling the plugins I had installed previously and were running fine, the same thing happened. I would click on Save at the settings after installing a plugin and the spinning wheel would appear on the save button and not disappear. Again, can ping and SSH into the Pi without issue. If I have the webcam tab up when this happens, that is still running and if I move the camera around it reflects that. Again, if I reboot the Pi via SSH (or powering off and back on) I cannot get back into the web interface.

I tried a different SD card and I go through the setup process then the same thing will happen again while installing plugins. It seems to get to a point where the web interface just hangs - perhaps after a period of time rather than by any action I am doing. I have tried different browsers as well as different PCs to connect to the web interface.

I will reflash an SD card again and this time not install any plugins and see what happens.
As the issue is continuing I'm assuming what I initially did is coincidence, unless the Pi itself is damaged somehow.

I have tried using both Wifi and LAN connection and both gets the same behaviour.

Setup info:
Raspberry Pi 3B (definitely not the + as I've had this before they came out)
Octopi version latest - file I've been flashing is called "2018-04-18-octopi-stretch-lite-0.15.1"
Octoprint version is 1.3.8 (I think. Whatever the latest is)

Logs (I was only able to add one attachment as I'm new):
octoprint.log (40.7 KB)


#2

It looks like you are restarting it a bunch of times. Is that true?


#3

Yes, there would be a few restarts in the logs.
I was installing one plugin then restarting the service as prompted, then install the next plugin and restart the service when requested.
When installing the plugin, I would close the install window then click the Save button at the bottom of the options and then click the button to restart Octoprint.
After about the 4th plugin was when it seemed to hang after clicking the Save button. I would get the spinning wheel and it would just stay at that. Then if I restarted the Pi itself by either turning off and back on or via putty and reboot command the web interface would no longer load.

I am running a clean image at the moment and it seems stable. I don't have it connected to my printer and also haven't installed any plugins as yet. The plan is to take an image and then install a plugin. Take another image if successful and continue that way and see if it gets to a point where it seems to die again.