Lost All Plugins and Settings after 1.9.2 update

Hello,

I have upgraded to 1.9.2 and i lost all my settings and plugins. I tried safe mode, restore from backup but that did not work. I even re-installed 1.9.2 and tried to restore but that did not work either.
Octoprint looks like i've never installed any plugins and my settings and configuration are gone.

So i decided to re-install 1.9.0 and restore from backup and that worked with no issues.

now the strange part.

Today, I noticed that my printer stopped midprint and when i opened Octoprint i found out it self updated to 1.9.2 and all my settings and plugins are gone. i've tried restarting it and safe mode but no change.

why do I lose all settings and plugins with 1.9.2 and then cannot even restore from backup and also how come Octoprint self updated (I know no one will believe me).

I would appreciate any help.

Thanks

this is how my Octoprint looks now and support bundle is attached.

octoprint-systeminfo-20230828111915.zip (763.6 KB)

It seems your OctoPrint installation is not OctoPi.

With what guide or script did you install OctoPrint on your Linux system?

It appears OctoPrint is not running within a virtual environment.

That messes up all update attempts.

For you have a backup, I recommend a new install of OctoPrint with the help of:

I've been running Octoprint as a docker container for years and I have updated to newer versions so many times without issues. I've also restored from backup and it always worked.

This looks like a completely messed up install and I can only repeat what @Ewald_Ikemann told you, you should reinstall (e.g. with the linked deploy script) into a virtual environment.

Your issue is that you have OctoPrint installed into two Python versions. Your global Python 3.8 environment contains all your plugins and OctoPrint 1.9.0. Your global Python 3.10 environment contains no plugins and OctoPrint 1.9.2. According to your log you've been happily switching between both. That also explains why it "auto updated" - it didn't, you switched to your Python 3.10 install.

I just saw your reply that this is a docker container. Is that the official one? In any case, this is a mess that needs to be cleaned up and I'm sorry to say that I have no idea how it happened and I also can't help to clean it up, I can just tell you what's wrong here - two global python versions, both with different versions of OctoPrint installed fighting for being the default.

after multiple attempts to reinstall and restore, I found out that all my plugins now appear under the \plugins\lib\python3.10 folder. there is still copy of these plugin under the 3.8 folder but Octoprint 1.9.2 seems to be working fine now. I haven't done any thing I haven't attempted before but as some point it just worked. I've probably should have just manually copied all plugins from 3.8 folder to 3.10.

This how stuff gets messed up. Manually copying stuff across different Python versions will break things because they are installed for a different version.