M112 Error after Updating to Octoprint version 1.9.0

What is the problem?

After I updated to octoprint version 1.9.0, Octoprint is Force-sending M112 command to the printer at start of print job. Previous versions of octoprint worked without any issues.

What did you already try to solve it?

I rebooted octoprint into safe mode and printer seem to print without issue. I've can also print successfully directly from my Ender 3 3d printer.
octoprint-systeminfo-20230526222102.zip (426.8 KB)

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint 1.9.0 running on raspberry Pi 3B.

Hello @Loren_Melton !

So one of the 3rd party plugins is the culprit.

I assume it's this ridiculous long message for M117 that the printer firmware complains about.

Please use shorter filenames with no spaces.

| Send: N22 M117 Printing CE3E3V2_Slightly Over Engineered Trash Bag Roll Holder, Left with Recycle logo, by MaxT - Layer 1 of 250*65
| Recv: Error:No Checksum with line number, Last Line: 21

Try with disabling the Dashboard plugin.

I kept getting the warning message "Printer keeps requesting line 22 again and again, communication stuck" then octo print forces a M112 command to shut down. So I restarted octoprint in normal mode after getting it to print in safe mode and disabled all 3rd party plugins. I've been enabling the 3 party plugins one by one until I find the culprit. So far I got it to print with the Dashboard Plugin and the runout sensor plugins enabled.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.