M118 action command

What is the problem?

I’m trying to perform a M118 A1 action:poweroff from gcode file on SD card and then
G4 S60

What did you already try to solve it?

It seems to work when executing the gcode file from octoprints memory. But then the octoprint shutdown before M81 could be sent to the printer.

Have you tried running in safe mode?


Did running in safe mode solve the problem?

Didn’t try

Additional information about your setup

OctoPrint version, OctoPi version, printer,

Creality CR10 smart with a RPi 2 Zero powered by the printer. Moved around connectors on the 5v power board so I reconfigured the camera port to a powered USB A serial port.

Powers up the RPi 2 Zero and connects to the serial without any issue.

I’m trying to create an correct power off sequence to not corrupt the RPi SD card. A M81 kills the power and also the Pi.

My thought is to run a gcode file standalone on the SD. It first shutdown the Pi, dwells for 30 sec and then poweroff.

M118 A1 action:poweroff in a gcode file on the pi triggers action command plugin and the pi shuts off.

But doesn’t work with the gcode file on SD

What firmware is running on the printer?

The firmware must support sending the action to listening print hosts when printing from SD card. When you are printing from OctoPrint, it is easy for OctoPrint to see the communication and the firmware will send it straight back. It's likely that a stock manufacturer firmware has this disabled I guess.

I checked. It seems that you are correct.

It’s a CR10Smart and it’s stock firmware since there isn’t any other made yet. Creality hasn’t published source code either.

It’s so annoying. A thing that should be an easy task seems almost impossible.

I also tried to execute a file from RPi that is

M85 S60
M118 A1 action:poweroff.

The thought is the M85 would act as a M81 S60
(M81 doesn’t have option of delay)

Rpi shuts down as expected and after 60 seconds printer displays an error code instead of killing power.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.