M851 X... Y.... Z... commands appear to do nothing

What is the problem?

I just installed a new cooling fan mount that shifted the BLTouch probe over a bit so I need set that up.

I can't just reprogram/re-flash Marlin because I had spent a lot of time customizing this one for this particular machine and... that file has long been lost (old hard drive died). Not sure if I can pull it off Octoprint or something.

What did you already try to solve it?

I tried (in octoprint's command panel) using M851 X-59 Y-9 (proper BLTouch probe distance from nozzle) and then hitting send. It returns:

Recv: echo:Probe Z Offset: -2.80
Recv: ok

^SO it appears that it's only allowing me to change the Z offset but not the X and Y... but I do the following anyway: I send M500 to store settings, then M501 to load those settings (I've also tried just hitting M500) But... doesn't appear to actually change anything. Still homes to the same exact spot and I can't run mesh bed leveling because it errors out since the BLTouch is now over the edge of the bed.

I'm thinking that yeah for some reason it's just not letting me effect the X and Y offsets. I do remember setting this up in the configeration.h file before. Could that be why it's just not letting me change those values now? If so then I'm in bigger trouble because like I said, that file is long gone (unless I can get it off this micro sd card in the raspberry pi I'm using for OctoPrint...

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

Link to octoprint.log: https://drive.google.com/file/d/1oUYG7J5IPHcjL3ebpm3Yrcrd87857KFY/view?usp=sharing

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Marlin 1.1.9
Octoprint version: 1.5.2
Printer: CR-10S 400

Hello @creationsof12!

M581 is for RepRap firmware, not for Marlin:

I believe the GCODE you want is M851, not M581. In addition, Marlin 1.1.9 only supports adjustment in Z for this command, you'll need to upgrade to a newer version (2.0.x) for this to work.


I did use M851 - never heard of or used M581. That was a typo just in the subject title - my bad. Fixed. But dang, that's a huge bummer. Wondering if there's any other way around this OR if I can somehow extract all the information from the firmware that's currently loaded on my printer... know of a way? Otherwise I'm going to have to completely start from scratch.

Not that I know of. The M503 command will give you quite a lot of data about the configuration, though it is only the stuff that can be changed post-compile (such as your Z offset). Other than that... I think you'll have to start again but look in the Marlin configuration repository for an example for your printer.

They have some for the CR-10S:

Hopefully that would make the process easier.

Dang :frowning: What a bummer. Well I guess I'm either starting from scratch or just re-installing my not so great fan mount... will probably do that instead of starting over.

Anyway I really appreciate the answers. Thank you.

1 Like