Make sure the motors do not disingage during pause to change filament


#1

What is the problem?
I want to change filament when paused but I always seem to move the motors in some way then when I resume, it is of center, as if it is skipped.

What did you already try to solve it?
I used the GCODE examples given in the snippets for tthe pause and resume functions, I tried looking into changing the gcode but it does not seem to affect the pause motors at all. An example of a sample would be amazing.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)


#2

Think the behavior depends on your printers firmware. For Marlin you can use M18 or M84 to disable the steppers, but you have to specify which stepper should be disabled:
M18 E
or
M84 E
otherwise all steppers will be disabled.


#3

Hi, I am using Marlin 1.1.8 and the thing is I want the motors to stay engaged, not disabled. Is there a gcode to do that?


#4

O.k. as you said you want this for changing filament so I thought it was mandatory to disable only the E-stepper so it could spin free for a manual filament changing while the other steppers (X,Y,Z) stay engaged, that's what both of the commands above do (in Marlin you can use M18 or M84).

A M84 (M18) alone without a stepper declared will disable all steppers. So if you want (for whatever reason) all steppers stay engaged, just delete the M84 (M18) command.


#5

Does he want an X/Y home after the resume?


#6

No, it should just resume the print after the change. @BerndJM, thanks I will give it a shot :slight_smile: