Marlin Firmware issues

What is the problem?

I have decided to upgrade my printer from an 8bit MKS Gen L V1.0 board to a BTT SKR Mini V3.0 board (32 bit) with a BTT TFT35 E3 V3.0.1 display.

I have previously used Repetier firmware on the MKS board and liked the way it works, but the SKR board seems to call for the Marlin firmware.

The issue seems to be in getting the configuration.h file properly set to support that display.

What did you already try to solve it?

I have done a lot of searching for the proper settings, including downloading and checking the sample config files from the Marlin site. Nothing I have found so far seems to have a configuration to support that particular display.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Have not even gotten to connecting the board to octoprint or the printer since I cannot get the firmware to function properly.

Initially loading the Marlin firmware onto the sd card and powering on the board loads the firmware, which then immediately gives error beeps and the display shows "Marlin Mode" and nothing else. (92.5 KB)

My Configurarion.h and Configuration_adv.h files are attached
Using Marlin 2.1.2
Printer HE3D K280 (delta)
Octoprint on Ubuntu 22.04 LTS on an RPi 4B.

compiling it with VSCode as recommended by github and BTT.
The firmware seems to compile and load properly but is giving the errors noted.

The only display I can find that seems (possibly) supported for that board is the BTT_MINI_12864_V1 which is an alias for the FYSETC_MINI_12864_2_1 // Type A/B. NeoPixel RGB Backlight.

Does anyone have this board & display combo that is working with Marlin firmware?
If so it will be greatly appreciated if they would share the proper config so I can get mine working.

Since you have a BTT board and a BTT display I would think that BTT support would be helpful.

1 Like

Sorry I did not mention it, but I have already searched the data I could find there.
The FAQs show that the board only supports

2. Screen type requirements
The LCD screen only supports the LCD12864 model with the CR10_STOCKDISPLAY interface.

I have tried the following different displays shown in the Configuration.h file with no luck.
BTT_MINI_12864_V1 ( an alias for FYSETC_MINI_12864_2_1)
MKS_MINI_12864_V3 (another alias for FYSETC_MINI_12864_2_1)

The display I have is sold by BTT with that board so it seems it should work properly with the correct config but I am having issues with identifying the proper config for the firmware.

In fact, from Marlin2.1.2/Marlin/src/pins/stm32g0/pins/BTT_SKR_MINI_E3_V3_0.h I see this
#error "Only CR10_STOCKDISPLAY, ZONESTAR_LCD, ENDER2_STOCKDISPLAY, MKS_MINI_12864, FYSETC_MINI_12864_2_1, and TFTGLCD_PANEL_(SPI|I2C) are currently supported on the BIGTREE_SKR_MINI_E3."
which is why I am puzzled that the provided display seems to not be properly activated.

As @b-morgan already mentioned: You have a Marlin problem with a BTT board.
This is the OctoPrint support forum.

You may consult a BTT forum or the Marlin Git.

I had hoped that someone had experience in solving this type firmware issue and could help.


This way too deep in to Marlin stuff.
I won't deny that some specialists are here, but the probability to find some at the dedicated boards is much greater.

The BTT TFT35 is one of these ones that normally acts like a host to the printer, running it's own firmware to communicate with the printer & display stuff on the screen. It has two modes though, and can be set to '12864' mode which emulates the old character LCDs. So you won't find a specific setting for this LCD in touch mode in the configs, it works through a serial port.

I would recommend joining the Marlin Discord Server to find people who can help you specifically with this screen - I know some sense of how it works but nothing to do with configuring it, they've seen it all before and so can guide easily.

I have this set up and it works well for me. I am currently running Marlin 2.1.2 on an Ender 5+. I am using the CR_STOCKDISPLAY in configuration.h. I would suggest you may check Kersey Fabrication in You Tube who has put together some Marlin firmware packages albeit they are mostly for Creality/Ender printers. There are also example configurations files in the Marlin GitHub. I'm not familiar with your printer, but you may be able to find one similiar.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.