Might be a plug in issue or Octoprint or Octopi


#1

What is the problem?
Printer stopped responding to web page Z axis UP commands (x, y, and down still work)

What did you already try to solve it? Power off, power on, checked wires, reset both printer and Octopi. Finally did a restore to a backup on a different SD Card, which fixed it, and I still have the original SD card to pull files from if you need them

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)
Octopi version should be 14,

Octoprint should be 1.3.8,

printer is Anet A8,

firmware is the original firmware that it came with which gave me a warning about a fire hazard so I turned off the warning instead of fixing it.

All plug-ins should be up to date cuz I do updates daily, which leads me to believe that it might be a plug-in update, unfortunately, I only do updates weekly, so the last known good image is from 4-17 even tho it was working fine yesterday during the day, and the problem occurred last night.

The problem is that I have so many plug-ins, it could be any of them, none of them, or a combination of a few of them.

As for log files, I took the SD card out, and I can't access the log files now, and I didn't get any error messages on my screen, the only thing that happened was that nothing happened when I hit the UP button.

It worked fine when I told it to go UP using the printer buttons

I still have the original SD card, so I guess I could stick it back in and look up the log files, but, like I said, I didn't see any error messages

The other strange thing is that I have TWO of these printers with (I think) the same plug-ins and updates in each, which means that the other one should be broken too, but it's not

I haven't ruled out a faulty SD card, but, everything else seemed to work fine, so I wouldn't put it high on the list of probabilities


#2

Got the DisplayLayerProgress plugin installed by any chance? At least what you describe sounds very familiar right now.


#3

Yes, that is one of the plug-ins I have installed


#4

Aha, I see now. Should I put the old card back in, and uninstall that plug-in ? Or is there an update that I missed ?


#5

I would try uninstalling/disabling the plugin for now and reporting the issue with the plugin in the plugin's bug tracker.


#6

Okay. I'll put the old card back in, disable that plug-in, and see if the problem still exists, if so, I'll report it to that plug-in bug tracker. Thank you for the quick response :smiley:


#7
  1. List item. Removed backup imaged SD card

  2. List item. Reinstalled failed but current SD card

  3. List item. Turned off DisplayLayerProgress plugin (I left it installed, all I did was disable it)

  4. List item. UP button works again