Mingda magician X

What is the problem?

When starting a print the print stays about 1β€œ off the bed. The machine prints fine from SD card


What did you already try to solve it?

Fully updated firmware and octopi

Have you tried running in safe mode?

Not yet

Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Rpi 4
16 gig as card

browser.user_agent: Mozilla/5.0 (iPhone; CPU iPhone OS 16_3 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) CriOS/112.0.5615.167 Mobile/15E148 Safari/604.1
connectivity.connection_ok: true
connectivity.enabled: true
connectivity.online: true
connectivity.resolution_check: octoprint.org
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1200
env.hardware.ram: 914006016
env.os.bits: 32
env.os.id: linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 3 Model B Rev 1.2
env.plugins.pi_support.octopi_version: 0.18.0
env.plugins.pi_support.octopiuptodate_build: 0.18.0-1.8.1-20220524101555
env.plugins.pi_support.throttle_check_enabled: true
env.plugins.pi_support.throttle_check_functional: true
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 20.3.3
env.python.version: 3.7.3
env.python.virtualenv: true
octoprint.last_safe_mode.date: unknown
octoprint.last_safe_mode.reason: unknown
octoprint.safe_mode: false
octoprint.version: 1.8.7
systeminfo.generated: 2023-05-04T22:53:49Z
systeminfo.generator: systemapi


Is there any difference while starting the print between SD and OctoPrint printing?
Does the homing look different or is there an additional probing or something like that

When I start a print with the SD it works perfectly. When I start it with Octoprint it moves the nozzle about 1" off the build plate and start from there. After starting a print from Octoprint the homing was all off. When homing it kept nozzle at that same strange height and would not actually go back to where home is when I press home on the Mingda. I had to restart the Mingda, unplug the Octopi from the Mingda, and press Home for that to resolve itself. It's a really strange issue. I love Octoprint and would love to be able to use it for the Mingda as I've used it for my Ender 3.

Slice a 1x1x1mm cube and post the gcode file here. Copy it to your SD card and print it. Enable serial logging on OctoPrint, upload the gcode file to OctoPrint, and print it. Post the serial.log here.

My guess is that you will find that there are additional gcode commands in the serial log that didn't come from the actual gcode file. They most likely come from OctoPrint's GCODE Scripts (in Settings).

1 Like

either that or the printers firmware is adding gcodes in the background when printing from sd card
wouldn't be the first time a manufacturer did that

I assume that firmware is as "good" as the Creality ones.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.