Missing all response from printer after 30/60 seconds

#1

What is the problem?
octoprint receive messages from the printer for about 30 seconds and after that nothing at all.
this cause octoprint to didn't send any new command.
all

What did you already try to solve it?
-Change usb cable with a shielded cable.
-reinstall octoprint inside my raspberry pi 3 B+
-re-flash firmware inside my printer (tevo tarantula running marlin 1.1.9)
-removed auto-recognize firmware from settings.

Additional information about your setup
-OctoPrint version 1.3.10
-OctoPi version: 0.16.0
-printer: TevoTarantula
-firmware: marlin 1.1.9
-octoprint log: https://pastebin.com/MdsYVxQs
-serial log: https://pastebin.com/d2z1Zm2q
NB: brefore restart i've tried to print forcing "ok" from the blue button above the terminal.
After the restart the communication stopped after the last temperature log, i've also sended another g28 and another g29 but they arent logged yet.

#2

Link to contents of Javascript console in the browser

https://pastebin.com/iUhKFm2C

#3

All evidence seems to suggest that your printer isn't responding after six consecutive attempts. You might try manually setting the port and baudrate.

#4

oh, right, i forgot to write that i've already tried both to change the ports on the rasp berry and to manually set the baudrate and port from octoprint.

#5

It it were me, I'd camp out on the Terminal tab while it's connecting and look for responses from my firmware. I'd review my OctoPrint -> Settings -> Gcode Scripts to see which one happens on startup and if there are any blocking commands which could make the printer unresponsive upon handshaking with it.

1 Like
#6

thanks, i will try soon at possibile :smiley: really thanks

#7

I'm sorry, it's all empty, the printer is not sending any commands.

#8

I tried to change the printer firmware baud rate.
Initially it was set to 15200, I tried to increase it to 250000 but after exactly two answers it was blocked again.
later I tried with a lower baudarate, 38400 and it seems to have gone better. I received almost twice as many messages as I did in 15200, but it stopped after a while.

furthermore, I noticed (baud 15200) that when it crashes if I press the blue button"fake acknowledgment"below the terminal, it considers the command executed and sends the next one, the printer receives it without problems, executes it but does not respond.

#9

If it were me, I'd add a ferrite core to my serial cable. Either it's a serial connection problem or it's a problem with the printer board or firmware; it should keep responding. You might also try verifying that all connections are sound (like the thermistor).

#10

i use a shielded calbe, changed 2 times.
Anyway with pronterface or Cura from a pc work fine without any kind of problem :confused: i don't think the problem come from the printer.
It may be a power problem on the raspberry?

#11

Do you see a lightning bolt in your top menu of OctoPrint? I didn't see any corresponding messages in your log.

1 Like
#12

nope, i didn't see the bolt :confused: I can't figure out what is the problem, this weekend i will work on it and if i find something i will write here ;D