Missing Temperatures and WebCam 1.3.11

I just updated to 1.3.11 Neither Temp. Controls or Webcam are displaying

I restarted in safe mode and tried connecting in both my everyday Chrome Browser any my Firefox Browser with no plugins installed.

The console output in the browser is

Less has finished and no sheets were loaded.
(index):7047 Uncaught ReferenceError: $ is not defined`
    at (index):7047
(anonymous) @ (index):7047
packed_core.js?155e8a07:15415 Starting dependency resolution...
packed_core.js?155e8a07:15525 ... dependency resolution done
packed_core.js?155e8a07:15829 Initial application setup done, connecting to server...
packed_core.js?155e8a07:13565 Connected to the server
packed_core.js?155e8a07:13535 Safe mode is active. Third party plugins are disabled and cannot be enabled.
packed_core.js?155e8a07:15807 Finalizing application startup
packed_core.js?155e8a07:15691 Going to bind 32 view models...
packed_core.js?155e8a07:15762 Could not bind view model TemperatureViewModel to target #temp : ReferenceError: Unable to process binding "visible: function(){return visible }"
Message: visible is not defined
    at visible (eval at parseBindingsString (http://192.168.0.19:5000/static/webassets/packed_libs.js?2d66a338:11374:90), <anonymous>:3:60)
    at update (http://192.168.0.19:5000/static/webassets/packed_libs.js?2d66a338:11409:229)
    at a.B.i (http://192.168.0.19:5000/static/webassets/packed_libs.js?2d66a338:11378:286)
    at Function.Pc (http://192.168.0.19:5000/static/webassets/packed_libs.js?2d66a338:11357:355)
    at Function.Qc (http://192.168.0.19:5000/static/webassets/packed_libs.js?2d66a338:11357:133)
    at Function.aa (http://192.168.0.19:5000/static/webassets/packed_libs.js?2d66a338:11356:482)
    at Object.a.m.a.B (http://192.168.0.19:5000/static/webassets/packed_libs.js?2d66a338:11355:39)
    at http://192.168.0.19:5000/static/webassets/packed_libs.js?2d66a338:11378:273
    at Object.q (http://192.168.0.19:5000/static/webassets/packed_libs.js?2d66a338:11317:244)
    at m (http://192.168.0.19:5000/static/webassets/packed_libs.js?2d66a338:11377:318)
(anonymous) @ packed_core.js?155e8a07:15762
Pn @ packed_libs.js?2d66a338:11208
(anonymous) @ packed_libs.js?2d66a338:11229
(anonymous) @ packed_core.js?155e8a07:15725
Pn @ packed_libs.js?2d66a338:11208
(anonymous) @ packed_libs.js?2d66a338:11229
bindViewModels @ packed_core.js?155e8a07:15692
setTimeout (async)
(anonymous) @ packed_core.js?155e8a07:15825
fire @ packed_libs.js?2d66a338:3269
fireWith @ packed_libs.js?2d66a338:3399
done @ packed_libs.js?2d66a338:9306
(anonymous) @ packed_libs.js?2d66a338:9549
load (async)
send @ packed_libs.js?2d66a338:9568
ajax @ packed_libs.js?2d66a338:9207
OctoPrintClient.ajax @ packed_client.js?4965268c:145
OctoPrintClient.get @ packed_client.js?4965268c:158
OctoPrintSettingsClient.get @ packed_client.js?4965268c:1242
SettingsViewModel.self.requestData @ packed_core.js?155e8a07:4309
fetchSettings @ packed_core.js?155e8a07:15812
setTimeout (async)
(anonymous) @ packed_core.js?155e8a07:15882
fire @ packed_libs.js?2d66a338:3269
fireWith @ packed_libs.js?2d66a338:3399
done @ packed_libs.js?2d66a338:9306
(anonymous) @ packed_libs.js?2d66a338:9549
load (async)
send @ packed_libs.js?2d66a338:9568
ajax @ packed_libs.js?2d66a338:9207
OctoPrintClient.ajax @ packed_client.js?4965268c:145
OctoPrintClient.ajaxWithData @ packed_client.js?4965268c:154
OctoPrintClient.post @ packed_client.js?4965268c:166
OctoPrintClient.postJson @ packed_client.js?4965268c:179
OctoPrintBrowserClient.passiveLogin @ packed_client.js?4965268c:557
LoginStateViewModel.self.requestData @ packed_core.js?155e8a07:2431
onServerConnect @ packed_core.js?155e8a07:15862
(anonymous) @ packed_core.js?155e8a07:15880
fire @ packed_libs.js?2d66a338:3269
fireWith @ packed_libs.js?2d66a338:3399
deferred.<computed> @ packed_libs.js?2d66a338:3737
DataUpdater.self._onConnectMessage @ packed_core.js?155e8a07:13569
(anonymous) @ packed_client.js?4965268c:390
Pn @ packed_libs.js?2d66a338:11208
(anonymous) @ packed_libs.js?2d66a338:11229
OctoPrintSocketClient.propagateMessage @ packed_client.js?4965268c:389
(anonymous) @ packed_client.js?4965268c:484
(anonymous) @ packed_libs.js?2d66a338:11225
_t @ packed_libs.js?2d66a338:11213
(anonymous) @ packed_libs.js?2d66a338:11224
(anonymous) @ packed_libs.js?2d66a338:11229
onMessage @ packed_client.js?4965268c:483
EventTarget.dispatchEvent @ packed_libs.js?2d66a338:22528
(anonymous) @ packed_libs.js?2d66a338:23241
SockJS._transportMessage @ packed_libs.js?2d66a338:23239
EventEmitter.emit @ packed_libs.js?2d66a338:22444
WebSocketTransport.ws.onmessage @ packed_libs.js?2d66a338:25315
packed_core.js?155e8a07:15744 Did not bind view model UsageViewModel to target #wizard_plugin_tracking since it does not exist
packed_core.js?155e8a07:15744 Did not bind view model SoftwareUpdateViewModel to target #softwareupdate_confirmation_dialog since it does not exist
packed_core.js?155e8a07:15744 Did not bind view model SoftwareUpdateViewModel to target #wizard_plugin_softwareupdate since it does not exist
packed_core.js?155e8a07:2443 User Nicholas logged in
packed_core.js?155e8a07:15783 ... binding done
packed_core.js?155e8a07:15803 Application startup complete

To me it looks like some JavaScript is not getting loaded.

I'm running a Taz 6, Rasberry Pi on Raspbian (debian) 8 and use Git commits to keep everything up to date. I've been doing this for several years (over a couple of printers) with no problems until now.

Any ideas?

1 Like

From here and here (pulled into 1.3.11), it looks like you're seeing some sort of toggling off of the feature...?

@foosel

To me this looks rather like the browser having an outdated copy of the HTML page for some reason (it shouldn't, there's a ton of cache busting going on, but who knows). I suggest to clear your browser's cache, reload and see if that solves it.

To me this looks rather like the browser having an outdated copy of the HTML page for some reason (it shouldn't, there's a ton of cache busting going on, but who knows). I suggest to clear your browser's cache, reload and see if that solves it.

I attempted that, and incognito windows and multiple browsers with no change.

Also, my printer has an extruder and heated bed, so there shouldn't be any reason for it to be toggled off (and the printer profile has it all turned on).

Any other ideas?

So, after some changing this and changing that, I didn't get anywhere.

I blew my installation away and installed an Octopi image, updated it to 1.3.11 and all is good - I just need to get around to installing some of my customizations (light hooks, etc) and plugins.

Same error here "packed_core.js:15752 Could not bind view model TemperatureViewModel to target #temp : ReferenceError: Unable to process binding "visible: function(){return visible }"
Message: visible is not defined"

Any solution not reinstalling everything?

Upgrading to last commit and downgrading to 1.3.11 Release channel auto-solved this issue.

2 Likes

hi, i have the same error.
tried to switch to "maintenence" branch and update, then install from https://get.octoprint.org/latest - nothing changed...
could you give me more detailed guide - what have you done?
i dont want to reinstall everithing ((