Mjpg-streamer doesn't start with raspberrypi camera

Camera model
RaspberryPi Cameramodule

What is the problem?
mjpg-streamer doesn't start

What did you already try to solve it?

  • read many topics here.
  • stop services and try:
    • raspistill: success
    • start mjpg-streamer via start.sh: success
    • plug in a usb webcam: success

Logs (/var/log/webcamd.log, syslog, dmesg, ... no logs, no support)

Log after reboot and automatic start with "raspi" in /boot/octoprint.txt:

Additional information about your setup (OctoPrint version, OctoPi version, ...)
RaspberryPi 3
OctoPrint 1.8.6
OctoPi 0.18.0

Everything was working great before upgrading from an very old version (last upgrade 2019) and now webcam doesn't come up anymore. Hardware has not been touched.

htop automatic started mjpg-streamer:
webcamdNotWorking

htop while manual started mjpg-streamer:

htop automatic started mjpg-streamer with USB Webcam:

Please run vcgencmd get_camera and let me know what it reports.

You should be able to run the RPi camera in 'USB mode'. If you have no other cameras connected & just leave it in auto, it should work fine.

vcgencmd get_camera
supported=1 detected=1, libcamera interfaces=0

Hi Charlie,
I just started playing around with the config, due to the fact, that it doesn't run anymore. Normally there is just the Raspberry PI camera module installed. The USB Webcam was plugged in, just for debugging reasons.
I also changed the SD Card to the old one and it worked again with no changes.

Yeah, so this is exactly what I thought it was. I've written a few posts about this before but I'm too lazy to find them so I'll type it again.

Newer updates and images introduced this extra libcamera interfaces part to the response that broke the webcamd scripts detecting a RPi camera exists. This is a bug on recent 0.18 builds or anywhere you have run sudo apt update or sudo apt upgrade or equivalent.

If you list your video devices, even with a RPi camera plugged in it should show up, which means that it can be used in 'USB' mode as a normal v4l2/UVC camera type interface, rather than the RPi camera specific one. Set your options to camera="usb" and it should work fine.

Hi, I've tested it but this doesn't work for me.
Due to the fact, that I'm lazy too, I've just stopped debugging and decided to edit the webcamd service directly so it came up with the same options like I started it manually and now it works fine for me. Camera output is shown at Octoprint interface and that's all I wanted.

Thank you for your help.