Mjpg-streamer won't run on startup

Note: all commands are in bold

What is the problem?

I can run cd mjpg-streamer/mjpg-streamer-experimental and ./mjpg_streamer -i "./input_uvc.so" -o "./output_http.so". but I can't get it to run on startup

What did you already try to solve it?

Well, I followed this tutorial and it did nothing, when I entered sudo systemctl enable webcamd and it gave no output, didn't affect my UI either

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

octoprint-systeminfo-20220122180317.zip (90.5 KB)

Additional information about your setup

I am running Octoprint 1.7.3 off an HP desktop I booted into Ubuntu (no RPis online under 100 bucks)

What do you get when you enter

sudo systemctl status webcamd

● webcamd.service - Camera streamer for OctoPrint
Loaded: loaded (/etc/systemd/system/webcamd.service; enabled; vendor prese>
Active: failed (Result: core-dump) since Sun 2022-01-23 09:41:19 EST; 2min>
Process: 754 ExecStart=/home/liam/scripts/webcamDaemon (code=dumped, signal>
Main PID: 754 (code=dumped, signal=SEGV)

Jan 23 09:41:12 systemd[1]: Started Camera streamer for Octo>
Jan 23 09:41:19 systemd[1]: webcamd.service: Main process ex>
Jan 23 09:41:19 systemd[1]: webcamd.service: Failed with res>
lines 1-9/9 (END)

No to be rude, how does that help?

It indicates that mjpg-streamer is crashing. You said you can run it manually, but have you verified that you can run the script, exactly how the service file would be?

Maybe the files are different on Ubuntu, I did replace pi with my system name, I'm not sure what it is, but I can't test it, my webcams wires got cut, and I have to order a new one.

And I'll open a new topic about this, but whenever I boot octoprint on my desktop, it freezes completely within 1-4 minutes

What kind of desktop? Which os?

What do you mean by boot?
Starting the Octoprint server on your desktop or open the webinterface in your browser on your desktop?

What freezes? The desktop, the Octoprint server or the webinterface?

It's a HP desktop running Ubuntu, I set it to automatically boot octoprint, but I meant the device itself freezes, the cursor doesn't move when I move the mouse. And as I said earlier, the device freezes. I've tried connecting from a separate device, doesn't connect.

Ok I thought you where talking about a different desktop.

Did you start over with a fresh os after tried different tutorials or at least removed everything you did before you started with another one or are you running a mix out of 3 or more tutorials on the same system right now?
That could be the reason why it freezes.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.