Monoprice Maker Ultimate 2 Printing Error

What is the problem?
I am trying to print through Octoprint to my Monoprice Maker Ultimate 2. Octoprint connects to the printer without a problem. It can see the SD card and load any of the files on it. Octoprint can also send files that I uploaded to the printer. I can manually move the X/Y/Z axis on the printer through Octoprint. I can turn the fans on and off. I can start a print, but that is where the problem starts. Once I tell octoprint to print, everything looks like it is going well. Everything starts moving around and once the nozzle gets to the bed, Octoprint disconnects says there is an error and the bed immediately drops back to home. On the screen of the printer is the very disconcerting message of:

KILLED.

impresora parada

por favor, reinicie

I can then reboot the printer or tell Octoprint to Connect again and everything is well as long as I do not tell it to print.

What did you already try to solve it?

I tried turning off the sending checksum but that did not help. I saw this in a video for this printer, but it was with a much older firmware. I am VERY new to 3D printing so I am not sure what else to try.

I can print successfully from the SD card and from Cura through USB on my laptop.This text will be blurred

Logs (octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support!)

octoprint.log
serial.log

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible)
Octoprint: 1.3.12
Octopi: 0.17.0
Printer: Monoprice Maker Ultimate 2 (Weedo F150S)
Firmware: 2.2.8
Browser: Google Chrome 79.0.3945.117
Operating System: Windows 10 Home 1909
Hardware: Raspberry Pi 4B

EDIT: I have tried running Octoprint in safe mode and it did not make any difference.

Hi @WhiteNoseThunderPant!

This happend:
You set the nozzle temp to 150°C

2020-01-13 17:26:48,946 - Send: M104 S150

but the firmware overshoots:

2020-01-13 17:26:51,976 - Recv:  T:128.38 /150.00 B:37.50 /0.00 @:127 B@:0
2020-01-13 17:26:53,974 - Recv:  T:130.76 /150.00 B:37.44 /0.00 @:127 B@:0
2020-01-13 17:26:55,973 - Recv:  T:135.60 /150.00 B:37.40 /0.00 @:127 B@:0
2020-01-13 17:26:57,973 - Recv:  T:143.01 /150.00 B:37.35 /0.00 @:0 B@:0
2020-01-13 17:26:59,972 - Recv:  T:150.16 /150.00 B:37.46 /0.00 @:0 B@:0
2020-01-13 17:27:01,972 - Recv:  T:155.67 /150.00 B:37.35 /0.00 @:0 B@:0
2020-01-13 17:27:03,971 - Recv:  T:159.08 /150.00 B:37.35 /0.00 @:0 B@:0
2020-01-13 17:27:05,971 - Recv:  T:160.90 /150.00 B:37.29 /0.00 @:0 B@:0
2020-01-13 17:27:07,971 - Recv:  T:161.78 /150.00 B:37.33 /0.00 @:0 B@:0
2020-01-13 17:27:09,971 - Recv:  T:161.99 /150.00 B:37.33 /0.00 @:0 B@:0
2020-01-13 17:27:11,980 - Recv:  T:161.73 /150.00 B:37.33 /0.00 @:0 B@:0
2020-01-13 17:27:13,973 - Recv:  T:161.37 /150.00 B:37.25 /0.00 @:0 B@:0
2020-01-13 17:27:15,973 - Recv:  T:160.76 /150.00 B:37.23 /0.00 @:0 B@:100:

160°C is too much and the thermal runaway protection is initiated.

You may run an auto PID tuning for the nozzle to get a better heat up curve.
If the overshoot still persists, there may be another issue.

2 Likes

Hello @Ewald_Ikemann , thank you very much for your response!

So I checked out the link you gave and ran an Auto PID and this is the result:

Send: M303 E0 S200 C8
Recv: PID Autotune start
Recv:  T:22.27 /0.00 B:24.65 /0.00 @:127 B@:0
Recv:  T:22.70 /0.00 B:24.69 /0.00 @:127 B@:0
Recv:  T:25.45 /0.00 B:24.77 /0.00 @:127 B@:0
Recv:  T:31.09 /0.00 B:24.80 /0.00 @:127 B@:0
Recv:  T:38.75 /0.00 B:24.84 /0.00 @:127 B@:0
Recv:  T:47.76 /0.00 B:24.92 /0.00 @:127 B@:0
Recv:  T:57.85 /0.00 B:24.69 /0.00 @:127 B@:0
Recv:  T:67.54 /0.00 B:24.96 /0.00 @:127 B@:0
Recv:  T:77.32 /0.00 B:24.73 /0.00 @:127 B@:0
Recv:  T:86.94 /0.00 B:24.84 /0.00 @:127 B@:0
Recv:  T:96.59 /0.00 B:24.88 /0.00 @:127 B@:0
Recv:  T:106.87 /0.00 B:24.73 /0.00 @:127 B@:0
Recv:  T:116.38 /0.00 B:24.88 /0.00 @:127 B@:0
Recv:  T:125.68 /0.00 B:24.92 /0.00 @:127 B@:0
Recv:  T:134.82 /0.00 B:24.88 /0.00 @:127 B@:0
Recv:  T:144.10 /0.00 B:24.96 /0.00 @:127 B@:0
Recv:  T:153.76 /0.00 B:24.80 /0.00 @:127 B@:0
Recv:  T:162.94 /0.00 B:24.96 /0.00 @:127 B@:0
Recv:  T:171.88 /0.00 B:24.92 /0.00 @:127 B@:0
Recv:  T:180.77 /0.00 B:24.92 /0.00 @:127 B@:0
Recv:  T:189.92 /0.00 B:24.80 /0.00 @:127 B@:0
Recv:  T:199.49 /0.00 B:25.00 /0.00 @:127 B@:0
Recv:  T:208.67 /0.00 B:24.88 /0.00 @:0 B@:0
Recv:  T:215.83 /0.00 B:24.88 /0.00 @:0 B@:0
Recv: PID Autotune failed! Temperature too high
Recv: ok
Recv:  T:220.18 /0.00 B:24.92 /0.00 @:0 B@:0
Recv:  T:222.99 /0.00 B:24.92 /0.00 @:0 B@:0
Recv:  T:224.06 /0.00 B:25.00 /0.00 @:0 B@:0
Recv:  T:224.42 /0.00 B:25.00 /0.00 @:0 B@:0
Recv:  T:223.88 /0.00 B:24.92 /0.00 @:0 B@:0
Recv:  T:223.53 /0.00 B:24.96 /0.00 @:0 B@:0

It began cooling after that. I'm assuming that I need to manually adjust the PID settings, but I don't really understand where to start. I would appreciate some guidance.

Ok, so I figured out that sending M300 will show you the current PID values. I will follow the wiki you linked and adjust based on their recommendations to see if I can find working values.

I found this:


The TO in the second post reset the PID values to 0.0 each and ran the autotune again.
You should note your original PID values (M300) and compare them with the autotune run.

@Ewald_Ikemann, thank you again for this pointer. Unfortunately, no matter what values I pick, the autotune fails.

The strange thing is that when printing from SD or USB through Cura, the temp spikes around 20-25 degrees above the target temp everytime and then cools back down to the target temp and prints just fine. I'm guessing this is not normal. Is it Octoprint that kills the print or is it the printer? If it is the printer, I wonder why it does not kill the print from SD or Cura the same?

I don't know if this makes a difference, but I decided to try a hunch.

I set the target temp manually to 150C through Octoprint and let it get to the temp. Once it was stable, I started a print which had the initial temp at 150C. It stopped at the same spot. As soon as the bed raises up to the nozzle, the print gets killed every time, no matter what the temp is.

I even set it at 200C and started the print once it got there knowing it would want to drop to 150C and the print died as soon as the bed got to the nozzle.

I can do the same scenarios with Cura and the SD card and the printer just waits once the bed is fully raised until it gets to a stable target temp and then begins printing.

I'm starting to think I might return this printer and purchase one with a more definite compatibility with Octoprint since that is one of my main interests.

So I started a print and watched the temp. The print stopped before the temp got to the target temp. It is right when the bed and nozzle meet, the print job dies.