MP Maker Pro Mk1 print size error


#1

What is the problem?
the second time, and subsequent times, but not the first time, I try to print any uploaded file, I get a "this model exceeds the print area" warning.

What did you already try to solve it?
I just turned off the warning, but I'd like to know if there is a better fix?

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)

Everything is up to date current release versions and running on a rpi 3b+

additional information:

I have to refresh the connection after every print and the display on the actual printer never acknowledges a print is running.


#2

You may switch off the size check in OctoPrint Settings -> Features -> Enable... (the second item in the list.


#3

Yes I've done that. I was trying to see if there was a better fix?


#4

As you see, this feature is in Beta state. So it may not work that proper.


#5

Well perhaps the question should be: Why is a beta feature turned on by default?


#6

grafik


#7

Wildly guessing here, I think I would check your printer profile in OctoPrint.


#8

That ain’t it.

Profile is set to 300 x 300 x 400

It says Benchy is too big.


#9

Some of your code might be outside the printable area, most notable are printers that home outside of the printable space (mine homes to negative values for x, y, and z) or if your printer has a wipe zone that is at say X 310 Y0, and the gcode moves it to that location for a wipe.

You might wish to provide more details, printer size (actual printer), printer profile details, and a sample file that exceeds the print volume (or at least one that octoprint thinks exceeds it).


#10

Ding Ding! I think you may have solved the issue:

this is my start code:

G21;(metric values)

G90;(absolute positioning)

M82;(set extruder to absolute mode)

M107;(start with the fan off)

G28;(Home the printer)

G92 E0;(Reset the extruder to 0)

G0 Z4 E5 F500;(Move up and prime the nozzle)

G0 X-1 Z3;(Move outside the printable area) <--- this is probably causing the issue!

G1 Y60 E8 F500;(Draw a priming/wiping line to the rear)

G1 X-1;(Move a little closer to the print area)

G1 Y10 E16 F500;(draw more priming/wiping)

G1 E15 F250;(Small retract)

G92 E0;(Zero the extruder)

I use the same starting gcode on my MP select mini and have never gotten this warning before though.


#11

Yep. You've set absolute position mode, homed the motors and then you've tried to do what looks to be a relative-type of movement.


#12

X can’t be negative 1?


#13

That's why I was trying to point you toward your printer profile. If I'm not mistaken, the bounding box part of that is to allow your hotend assembly to move outside of the normal extents. Read the suggestion by DrGary in that thread.

Here's some related talk