Multiple cameras, 1 stopped working

Camera model
3 cameras: Pi Camera and 2 Logitech C615

What is the problem?
All three cameras worked fine for a long time, probably a year. Suddenly one of the Logitech C615 cameras isn't streaming.

What did you already try to solve it?
Swapped 2 USB cameras, tried different USB ports. I have DEFAULT (Pi Camera), TOP DOWN (failed USB cam), and Filament (working USB cam). If I swap the cameras USB ports nothing changes. I tried the camera on a Windows computer and it works fine.

Logs (/var/log/webcamd.log, syslog, dmesg, ... no logs, no support)
Starting up webcamDaemon...

--- Configuration: ----------------------------
camera: raspi
usb options: -r 640x480 -f 10
raspi options: -fps 10
http options: -w ./www-octopi -n

<13>Jun 20 12:29:56 pi: Starting Raspberry Pi camera
Running ./mjpg_streamer -o -w ./www-octopi -n -i -fps 10
MJPG Streamer Version: git rev: ddb69b7b4f114f3c2ca01adf55712792ca8aed43
i: fps.............: 10
i: resolution........: 640 x 480
i: camera parameters..............:

Sharpness 0, Contrast 0, Brightness 50
Saturation 0, ISO 0, Video Stabilisation No, Exposure compensation 0
Exposure Mode 'auto', AWB Mode 'auto', Image Effect 'none'
Metering Mode 'average', Colour Effect Enabled No with U = 128, V = 128
Rotation 0, hflip No, vflip No
ROI x 0.000000, y 0.000000, w 1.000000 h 1.000000
o: www-folder-path......: ./www-octopi/
o: HTTP TCP port........: 8080
o: HTTP Listen Address..: (null)
o: username:password....: disabled
o: commands.............: disabled
i: Starting Camera
Encoder Buffer Size 81920

Additional information about your setup (OctoPrint version, OctoPi version, ...)
Running completely up-to-date Octoprint 1.4.0 and all updates applied using Webmin to OS.

I swapped cameras around and rebooted and the issue resolved itself.

1 Like

Do you mind sharing how you got the 2 usb cams working?

@Slacker, I'm curious how you setup the multiple cameras as well if you have time to do a write up.


If you can see the camera on your local network with SADP, you need to either plug the camera into a separate PoE switch/injector or directly into your router. In those cases, you will need an IP utility tool from the camera's manufacturer or you will need to access your router directly to see if the device appears in the list of devices.
I would tell you that the camera is most likely faulty if it cannot be hard reset or it doesn't show up on the network after hard resetting it.

Thank You.