Multiple Octoprints have appeared after Update


#1

Yesterday my Pi told me that Octoprint had an upgrade available and asked if I wanted it. I said yes :slight_smile: Unfortunately this broke TouchUI AND I now have two Octopi servers showing one on the original IP address and another on a completely new address.

I have tried multiple rebootings and verified that the DHCP is giving the right address out for this MAC so somehow the printer has added an address.


#2

From what I understand, the new 1.3.9 OctoPrint adds IPv6 support. It's normal for it to now bind to three addresses:

127.0.0.1
some IPv4 address (like 192.168.1.20)
some IPv6 address (like fc00:0:0:0:192:168:1:20)


#3

Could also be ethernet and wifi both active?


#4

True, so true.

I can imagine a scenario where TouchUI doesn't work on the IPv6 side of things resulting in a different-looking OctoPrint on one of the addresses.


#5

Hi All, sorry for the late reply I forgot my password then struggled to fix it!

The address that appears is always 192.168.1.141. No idea why however this is an IPv4 not 6. I have figured out that when I initially setup the server it only has one IP address. The second appears after a little while, possibly after I attach to the printer using the octoprint stuff in Cura. Maybe that generates another IP?


#6

You could login via ssh and call the network info with

ifconfig

eth0 gives you the info to your lan connection and
wlan0 the infos the wifi connection.
Both including IP4 and IP6 of the connection


#7

If you ssh into your Raspberry Pi, the welcome screen should indicate which IP addresses that it's bound to.

------------------------------------------------------------------------------
Linux charming-pascal 4.9.80-v7+ #1098 SMP Fri Mar 9 19:11:42 GMT 2018 armv7l

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Mon Jul 30 22:20:52 2018

Access OctoPrint from a web browser on your network by navigating to any of:

    http://charming-pascal.local
    http://10.20.30.250
    http://2600:8801:9908:a200:17ea:82c4:c397:e962

https is also available, with a self-signed certificate.
------------------------------------------------------------------------------
OctoPrint version : 1.3.9
OctoPi version    : 0.15.0
------------------------------------------------------------------------------

I'm reasonably certain that it's also bound to http://localhost, a.k.a. http://127.0.0.1.

I'd be curious to see what you're seeing. When you suggest there's another IP address, please show the command that you're using and its output.


#8

It does indeed, it shows two iPv4 addresses. The one I assigned to the Pi via DHCP, plus one that has appeared from nowhere. It's my need to know why I have this extra address that spurred the question. I feel uncomfortable when systems are creating their own addresses that I don't understand.


#9

When you plug in a lan cable to your raspi, the router gives this connection an IP.
When the WiFi of the raspi is active, the router gives this connection another IP.
Reason: The lan chip and the WiFi chip have their own MAC addresses. These should be unique for every chip in the world - usually. But a lan chip and a WiFi chip definitely have different mac addresses.
The router distinguishes chips by these MAC addresses and does not know if they are on the same board.
If you just want to have only one connection to the raspi, you either have to unplug the lan cable or disable the wifi.
As said above, "ifconfig" as a SSH command gives you the information what IP belongs to what connection.


#10

Yep, I don't have both connected. Unless somehow an address is being applied to the Lan port via the wireless even though it is not connected. Still weird. And it is weird that it does not appear immediately. Right after setup it only had one IP address. The second appeared a little while later, possibly when I connected Cura. I wonder if Cura somehow causes this...


#11

Thanks for that clarification! And it's wired too.
As if something virtual is initiated then.
You mean the Cura on the PC or the Cura within OctoPrint?
I do not work with Cura on the Pi, but I check both out.


#12

I use the cura on my desktop, not the one on octoprint. That one seems to be a number of versions behind. I connect the desktop cura to the printer so I can connect directly for controlling the printer and or kicking off prints if they are small. I'm powering the PI from the printer and usb connecting there too and don't want to connect it using cat5 as that will limit my mobility. If the filament I use is smelly then the printer is not allowed in the house :wink:


#13

Okay, so now you need to run some commands to find out what is attached to each:

sudo netstat -anp | grep -v CONNECTED | grep -v DGRAM | grep -v "::" | grep -v TIME_WAIT