Multiple printers/instances of Octoprint,

What is the problem?

I'm attempting to create multiple instanced of OctoPrint on a single RPi. The "symlinks" for the USB ports are not being created, apparently. Cannot find any error messages in logs I've checked.

What did you already try to solve it?

Created, or tried to create, symlinks following a blurb found in the "MegaThread".

Have you tried running in safe mode?


Did running in safe mode solve the problem?

No, seemed inappropriate.

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!) (172.1 KB)

I always mess this up. Bear with me while I find how to upload it again.

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

1.87. -- Windows 10 -- FF 110.0.1 64 bit

Please tell us how you tried to create the symlinks

Follow the link to octoprint_deploy. It does exactly what you want.

Thanks. Look quite impressive. I will give it a go.

I attempted to create them by creating a file /etc/udev/rules.d/99-usb.rules, containing lines like
SUBSYSTSEM=="tty", ATTRS{idVendor}=="2341", ATTRS{idProduct}=="0042", ATTRS{devpath}=="1.4", SYMLINK+="ttyMINE"
SUBSYSTSEM=="tty", ATTRS{idVendor}=="2341", ATTRS{idProduct}=="0042", ATTRS{devpath}=="1.4", SYMLINK+="ttyMINO"

But after reboot, they did not appear. I just realized that I have no ttyUSB0 and ttyUSB1 devices, they are ttyACM0 and ttyACM1, so. perhaps I should have named the file "/etc/udev/rules.d/99-acm.rules" ?

But, I just renamed it and did "sudo udevadm control --reload" and still do not see the symlinks.

I am passingly familiar with Linux but creating symlinks for devices is entirely new to me.

It will never work when all the information is identical. This is why I suggest using the octoprint_deploy script to handle multiple instances. If you don't want to do that, there is a secondary script as part of octoprint_deploy that will create udev rules for you (

Oh, I knew that part. The second line is a visual tribute to my carelessness in cutting and pasting between ssh (putty) and Windows. The values are all unique.

So using the script, managed to create the symlinks and added them as additional ports, to which I could then connect each printer.

I must complement you on your efforts to create the scripts and guide the experientially challenged.

I'll get back here if I run into any related problems along the way.

Decided to use First few steps went as expected but then was presented with: "If you have generated service files for OctoPrint, please stop and disable them".

Did not see that mentioned in the instructions and quit at that point to be certain what that meant. Is it referring to systemd files?

Also, must Octoprint be stopped when running this script?

It has detected that you already have been running OctoPrint. If you have service files running as part of any previous installation you may end up with conflicts. If you are doing this with OctoPi it will automatically turn those services off for you.

You are always better off starting from scratch, as the script can't detect every possible scenario where someone has tried to do a manual installation.

Seems so. I tried "backing out" after muddling through and ended up being unable to login via web to Octoprint. I'd considered starting fresh and may do that if I can't iron that out. I have properly followed, I think, the change octoprint password procedure outlined elsewhere

Not a big deal in this case..

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.