Multiple printers per server megathread

I understand the reasons not to run multiple instances on one pi. I'm migrating to Octofarm bc I have too many printers, like one does. I'm willing to consider a pi per printer but I'm shooting for the cheapest way to go. I'm guessing that the Rpi 3B+ is the way to go? Is there a cheaper functional option? I'd try the zero w but for many many reasons this whole farm is wired not wifi.

What kind of printers do you have? I mean, a dozen Prusas or three $85 Monoprice deltas?

A bit of a hodgepodge really: Ender 5, CR6-SE, MPSM, MPMD, Lottmax Shark (Dual), and a couple of tenlog dual hotend printers

For now at least :joy:

What is the problem?

I have multiple instances of octoprint on my rpi 4. They were working properly. Now, I can start instance 2 at port 5001 but the original will not start with port 5000 or without any port number. When I enter my ip address 192.168.1.210 or 210:5000 I get an unable to connect message. If I enter 192.168.1.210:5001 it connects without any problems.

What did you already try to solve it?

I double checked all of the settings on my rpi.
When I connect to instance 2 I can change the USB port and connect to the printer on instance 1 but it is still on port 5001, not 5000.

Have you tried running in safe mode?

I cannot get that far.

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

Additional information about your setup

OctoPrint version 1.5.2, OctoPi version 0.17.0, printer CR-10s, firmware, browser: chrome and firefox, operating system, Windows 10 as much data as possible

To quote the message template: "No logs? No support!"

It's hard to know without any logs.


Ultimately you should be in this thread, though:

If octoprint won’t start you cannot get a log file.

You say "didn't start", it appears that means the web service didn't come up. Much would emit logs before that, there should be some startup noise.

How are you starting it?

Ok, I’m using wrong terminology and got some more information this morning. I turn on both of my printers and wait for them to boot up. Then I turn my Pi on and the printers re-boot. I put the ip address in my web browser and instance 2 at port 5001 comes up but instance 1 at port 5000 will not connect. In Chrome I get the message “This site can’t be reached 192.168.1.210 refused to connect. I did a status check on octoprint and octoprint2, both shows they are running. I tried stopping and restarting octoprint but I still cannot connect with my web browser. I use Putty to access the rPi so if there is a way to get log through Putty I can do that.

Gary Struckmeier

gls@nelsonleather.com

This post shows where the logs are on all platforms:

Thank you for all your help. I finally decided it would be quicker to just do a clean install and start fresh.

Gary Struckmeier

gls@nelsonleather.com