My Octopi wont connect to MakerBot Replicator 1

What is the problem? Whenever try to connect my octopi to the printer, it will try connecting for about a minute, then stop. And it will say that it is offline.

What did you already try to solve it? I unchecked Request exclusive access to the serial port. I tried all the baudrates including auto. I Re-Flashed octoprint. And i remade the printer profile.

Connecting to: /dev/ttyACM0
Changing monitoring state from "Offline" to "Opening serial port"
Connected to: Serial<id=0x6bcd3690, open=True>(port='/dev/ttyACM0', baudrate=115200, bytesize=8, parity='N', stopbits=1, timeout=10.0, xonxoff=False, rtscts=False, dsrdtr=False), starting monitor
Changing monitoring state from "Opening serial port" to "Connecting"
Send: N0 M110 N0125
Send: N0 M110 N0
No answer from the printer within the connection timeout, trying another hello
Send: N0 M110 N0*125
There was a timeout while trying to connect to the printer
Changing monitoring state from "Connecting" to "Offline"
Connection closed, closing down monitor
octoprint (1).log (93.5 KB)

Additional information about your setup (OctoPrint version, OctoPi version, MakerBot Replicator 1, sailfish firmware, google chrome. The printer itself still works when i print from Sd

This was working or a few weeks, until i moved my Pi over to my anet a8. It worked just fine on my anet, but when i moved back over to the replicator, it stopped working. although it still works fine on my anet.

Any help would be Awesome!

Oh! I found the problem. When i switched to my anet, the gpx plugin disabled. I enabled it and now it works.

1 Like