My printer wont print whenever i click the load and print button

What is the problem?

Whenever i click the load and print button, it wont do anything. No response at all, and it basically looks like i never clicked it in the first place. This happened after an update to UI Customizer, although even though i disabled it, it still has the issue.

What did you already try to solve it?

Disabled UI Customizer, Restarted OctoPrint

Have you tried running in safe mode?


Did running in safe mode solve the problem?

No, same issues as before

Complete Logs

2021-03-27 23:06:59,097 - octoprint.printer.standard.job - INFO - Print job selected - origin: local, path: V2__Mini_Folding_Knife_non_serrated_Blade_NEW_0.2mm_PLA_ENDER3_1h14m.gcode,
owner: RioWolf, user: RioWolf
2021-03-27 23:06:59,119 - octoprint - ERROR - Exception on /api/files/local/V2__Mini_Folding_Knife_non_serrated_Blade_NEW_0.2mm_PLA_ENDER3_1h14m.gcode [POST]
Traceback (most recent call last):
  File "/home/pi/oprint/local/lib/python2.7/site-packages/flask/", line 2447, in wsgi_app
    response = self.full_dispatch_request()
  File "/home/pi/oprint/local/lib/python2.7/site-packages/flask/", line 1952, in full_dispatch_request
    rv = self.handle_user_exception(e)
  File "/home/pi/oprint/local/lib/python2.7/site-packages/flask/", line 1821, in handle_user_exception
    reraise(exc_type, exc_value, tb)
  File "/home/pi/oprint/local/lib/python2.7/site-packages/flask/", line 1950, in full_dispatch_request
    rv = self.dispatch_request()
  File "/home/pi/oprint/local/lib/python2.7/site-packages/flask/", line 1936, in dispatch_request
    return self.view_functions[rule.endpoint](**req.view_args)
  File "/home/pi/oprint/local/lib/python2.7/site-packages/octoprint/server/util/", line 1539, in decorated_view
    return func(*args, **kwargs)
  File "/home/pi/oprint/local/lib/python2.7/site-packages/octoprint/server/api/", line 802, in gcodeFileCommand
    printer.select_file(filenameToSelect, sd, printAfterLoading, user)
  File "/home/pi/oprint/local/lib/python2.7/site-packages/octoprint/printer/", line 680, in select_file
    tags=kwargs.get("tags", set()) | {"trigger:printer.select_file"},
  File "/home/pi/oprint/local/lib/python2.7/site-packages/octoprint/util/", line 1599, in selectFile
    filename, self._currentFile.getFilesize(), False, user=user
  File "/home/pi/oprint/local/lib/python2.7/site-packages/octoprint/printer/", line 1545, in on_comm_file_selected
    self._setJobData(full_path, size, sd, user=user)
  File "/home/pi/oprint/local/lib/python2.7/site-packages/octoprint/printer/", line 1282, in _setJobData
    and "estimatedPrintTime" in fileData["analysis"]
TypeError: argument of type 'NoneType' is not iterable

i couldn't get complete logs, but this is what came from when i clicked the button, so i hope its enough.

Additional information about your setup

version 1.5.3
my plugins are:
Bed Leveling Wizard
Firmware Check
Printer Dialogs
Printer Notifications
Simple Emergency Stop
Slicer Print Time Estimator
Top Temp
Virtual Printer
my printer is an ender 3 pro and my web browser is brave, and i run windows.

tagging @Laze :slight_smile:

Can you look in your developer console in the browser? Any errors there.

I have one similar report on GitHub: I cant print anything. · Issue #116 · LazeMSS/OctoPrint-UICustomizer · GitHub

Aldo it might be a combination of plugins. So maybe try disabling other plugins and leaving UI customizer enabled. So we can figure out the combination

Well i just tried re-slicing the file and using that, and it worked. So im not sure if octoprint found issue with my file, or something got corrupted, or something just didn't work right. I should probably use different files before I start a post. anyways, thanks for helping me.

Was it solved?