NavBar Icons Not Appearing, Including Safe Mode

What is the problem?

When using Octoprint, only a select few navbar icons appear--Emergency Stop, Settings Wrench, Power Button, and Username dropdown.

I was looking to use the Consolidated Tabs third party plugin, but noticed there was no pencil icon they use to make edits.

I also realized upon looking in UI Customizer > Top icons tab, that I should have access to icon which are hidden in the NavBar, which I do not: Action Command Prompt Support, Firmware Updater, Logging Seriallog, Logging Plugintimingslog, Pi Support Plug In.

What did you already try to solve it?

  • I ran Octoprint in Safe Mode and this did not solve the issue.
  • I turned off all plug ins by process of elimination to see if that would affect anything. No change.
  • I cleaned up the data (eraser button) of all third party plug ins. No change.
  • I used inspect and saw the following error message: "The resource at “http://octopi.local/static/vendor/fontawesome-6.1.1/webfonts/fa-brands-400.woff2” preloaded with link preload was not used within a few seconds. Make sure all attributes of the preload tag are set correctly." Not sure if this is related. I was first thinking it would be a font related issue but icons did appear briefly (see image) which makes me think not.
  • Tried running Octoprint in Firefox (primary use browser), Chrome and Safari. All instances experienced the same issue.

Odd thing that I did notice--in UI Customizer when I hit preview, I was able to see those hidden icons from the previous point, but not the one for Consolidated Tabs. (see image)

in UI customizer preview:

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle (1.3 MB)

Additional information about your setup

  • OctoPrint version 1.9.3
  • OctoPi* 0.18.0 (build 2022.01.20.12925)
  • Python 3.7.3
  • Heavily modded Ender 3 with a BIGTREETECH SKR Mini E3 V1.2 board
  • Marlin 2.32 from TH3D
  • Firefox, Chrome, Safari
  • Windows 10 and macOS Ventura 13.6.2

You're worrying over a problem that doesn't exist.

These icons are hidden because they do not apply to the current situation - they are not supposed to be there all the time. To specifically list them:

  • Logging ones: only show up if you enable the relevant logs, to remind you they're on
  • Pi Support: this either shows an undervoltage or overheating icon flashing in the navbar, if either of those are happening. You never want to see this!
  • Action command prompt: only shows if there is a message from your printer for you to view.
  • firmware updater: optional, in the plugins settings you can enable showing a navbar icon as a shortcut, disabled by default.

No worries, good to know those are hidden by default.

However—my main issue is I’m still looking for the pencil icon to use Consolidated Tabs and it’s not there. I’ve also tried zooming out on the page, etc.

I’ll leave a report with the creator of the plug in. Thanks for your help!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.