🇺🇦 We stand with Ukraine! 🇺🇦

Need Cura profile for Taz 6

This needs a bit of background. I have been printing using cura-lulzbot edition for couple of years printing from SD cards. I've been running cura on a Linux mint 19.1 system to slice and generate gcode. Recently, there was an update to Cura that broke it (it is requiring a newer version of glibc.) I have reported this issue, but it does not look like a fix is coming soon. I attempted to install slic3r as a work around, but that just core dumps on me.

Needing a means of slicing, I ordered a raspberry pi 3 B+ and installed OctoPi. Only to find that in order to get it to slice, one must run cura on a different machine and export its .ini file.

Given that I can't currently run cura on another machine, I am stuck.

I was under the impression that OctoPi included a complete version of cura, and I would be able to change the settings, and download new firmware using it. I would adjust the settings pretty much every time I printed depending on how strong and how detailed I needed the print to be.

Have I completely misunderstood what the slicing capability of OctoPi is?
Is there a way I can get this set up to work?
At the very least, I need a cura profile for the Taz6 for NGEN plastic.

I'm a little worried that the latest version of Cura uses new commands in the gcode that were added in the latest firmware for the Taz6, so I'll need to be able to update the firmware as well.


OctoPrint originally included this functionality and it probably worked out great then. The embedded Cura engine in OctoPrint has not changed much since those early days and all the while the stand-alone version of Cura—as developed by Ultimaker and the open source community—leaps ahead in versions. Even if you did want to use this embedded Cura, you'd have to provide a profile which would be exported from some early version of stnad-alone Cura that's probably no longer available.

As a result of all this, the next major release of OctoPrint will have unbundled this embedded Cura engine as part of the core functionality at least.

Your best course of action would be to downgrade your stand-alone version of Cura to the one you know works for you. You could begin by downgrading your glibc (or perhaps not).

Believe it or not, this world of open source (although it requires some knowledge) allows each of us to really control what's on our computers. You're just as free to downgrade software as to upgrade it; the choice is your own.

Since you are familiar with CuraLE, I'd suggest trying Ultimaker's Cura:

Ultimaker's version is a bit ahead of the LulzBot Edition and version 4 has a new user interface. You could try one of the version 3 downloads if the new user interface isn't to your liking.

There is an OctoPrint plugin, Firmware Updater, that can be used. I'm running CuraLE on Windows and my TAZ 6 is connected to OctoPi / OctoPrint so I use the plugin to change / update the firmware. You can download the latest firmware from http://devel.lulzbot.com/software/Marlin/

IMO, this is also a workable solution.

Another possible workaround would be to run VirtualBox or some other virtual machine software on your current system and install an OS that does work with the latest CuraLE.

1 Like

And I wouldn't be surprised if there's not a Docker version of this solution as well.

I am able to run the ultimaker cura version 4.0.0 Appimage. I was able to find profiles for the nGen plastic I have, but I was not able to find a profile for the Taz6, or even a way to import a printer profile.
I can create a profile by manually entering the data, but the start and end gcode for the Taz6 is rather complex, and I would prefer to be able to transfer it from the cura-lulzbot, but since I can't run the cura-lulzbot right now, I'd have to go digging for the files, and hope I found the correct version.

Can anyone point me at the directory where cura-lulzbot stores its printer profiles? What are the file names? Any way I could add the model of the Taz 6 print bed that the cura-lulzbot shows to the ultimaker version?


Isn't it available here? Guess not.

Are these useful?

I was basically chasing links on the right hand side of this page.

Here's the Machine Settings (Printer and HotEnd) and text files for the StartCode and EndCode for a TAZ 6 from CuraLE 3.6.3 (Windows 10 but the text files have Unix line endings).

TAZ6.zip (36.3 KB)

1 Like

Update: I have successfully installed the firmware updater on OctoPi, and updated my printers firmware.
It was necessary to do it this way as I could find no way to connect cura version 4.0.0 to my printer (locally connected through USB. This was the way I would update my firmware with Cura-Lulzbot).

I have used B-Morgan's setup information and successfully generated g-code, but I don't know what to do with the hex file he included.

My plastic has been soaking up moisture for several months while my printer was idle, so I am baking it now to dry it out. I will attempt to print tomorrow.

I attempted to mount the Raspberry Pi to the side of my printer (it has mounting holes specifically for this), but I managed to break one of the only four standoffs I had. I've ordered replacements, but until they arrive, the pi will be flopping around on the bench by my printer.

The startup code for CuraLE 3.6.3 is not compatible with Cura 4.0.0

This is the output of Cura 4.0.0 for the startup code:

;Filament used: 8.54348m
;Layer height: 0.4
;Generated with Cura_SteamEngine 4.0.0
M82 ;absolute extrusion mode
;This G-Code has been generated specifically for the LulzBot TAZ 6 with standard extruder
M73 P0				; clear GLCD progress bar
M75				; start GLCD timer
G26				; clear potential 'probe fail' condition
M107				; disable fans
M420 S0				; disable previous leveling matrix
G90				; absolute positioning
M82				; set extruder to absolute mode
G92 E0				; set extruder position to 0
M140 S85	; start bed heating up
M109 R{material_soften_temperature}	; soften filament before homing Z
G28				; Home all axis
G1 E-30 F100			; retract filament
M109 R{material_wipe_temperature}	; wait for extruder to reach wiping temp
G1 X-15 Y100 F3000		; move above wiper pad
G1 Z1				; push nozzle into wiper
G1 X-17 Y95 F1000			; slow wipe
G1 X-17 Y90 F1000			; slow wipe
G1 X-17 Y85 F1000			; slow wipe
G1 X-15 Y90 F1000			; slow wipe
G1 X-17 Y80 F1000			; slow wipe
G1 X-15 Y95 F1000			; slow wipe
G1 X-17 Y75 F2000			; fast wipe
G1 X-15 Y65 F2000			; fast wipe
G1 X-17 Y70 F2000			; fast wipe
G1 X-15 Y60 F2000			; fast wipe
G1 X-17 Y55 F2000			; fast wipe
G1 X-15 Y50 F2000			; fast wipe
G1 X-17 Y40 F2000			; fast wipe
G1 X-15 Y45 F2000			; fast wipe
G1 X-17 Y35 F2000			; fast wipe
G1 X-15 Y40 F2000			; fast wipe
G1 X-17 Y70 F2000			; fast wipe
G1 X-15 Y30 Z2 F2000		; fast wipe
G1 X-17 Y35 F2000			; fast wipe
G1 X-15 Y25 F2000			; fast wipe
G1 X-17 Y30 F2000			; fast wipe
G1 X-15 Y25 Z1.5 F1000		; slow wipe
G1 X-17 Y23 F1000			; slow wipe
G1 Z10				; raise extruder
M109 R{material_probe_temperature}	; wait for extruder to reach probe temp
G1 X-9 Y-9			; move above first probe point
M204 S100			; set probing acceleration
G29				; start auto-leveling sequence
M420 S1				; activate bed level matrix
M425 Z				; use measured Z backlash for compensation
M425 Z F0			; turn off measured Z backlash compensation. (if activated in the quality settings, this command will automatically be ignored)
M204 S500			; restore standard acceleration
G1 X0 Y0 Z15 F5000		; move up off last probe point
G4 S1				; pause
M400				; wait for moves to finish
M117 Heating...			; progress indicator message on LCD
M109 R240	; wait for extruder to reach printing temp
M190 S85	; wait for bed to reach printing temp
G1 Z2 E0 F75			; prime tiny bit of filament into the nozzle
M117 TAZ 6 Printing...		; progress indicator message on LCD

Note that {material_soften_temperature} and {material_probe_temperature} did not get replaced with values as they should.

I'm not sure if this is because these are things added by Aliph Objects to their CuraLE version, or because they were removed in version 4.0.0.

In any case, my problems are veering very far away from OctoPI, so I probably need to find the correct forum for this.

These are things added by Aleph Objects to their CuraLE version

Update: I hard coded the values that cura 4.0.0 did not understand, and succeeded in printing.

Oddly, OctoPi seemed to lock up (my browser lost connection to it and could not re-connect) about an hour into a 5 hour print. The print completed anyway.

Thanks for the help.

This most likely is a (wireless) network problem. I had a similar problem that was fixed when I rebooted my wireless access point.

Hi, did you ever get you TAZ6 working with proper CURA? I've been trying and just getting python crashes

I just downloaded the Cura package from the ultimaker website, mark it executable and run it.
These are self contained executibles with all the dependencies embedded in the executable.
I'm still not connecting Cura to my printer, I am either using the SD card, or uploading the file to Octoprint.

Ultimaker Cura has an OctoPrint Connection plugin to handle both the transfer of gcode and the monitoring of the printing process. You get this through the Ultimaker Marketplace.

This works for me with Ultimaker Cura 4.6.1 on Windows 10 talking to my TAZ 6 connected to an RPi 3B running OctoPi 0.17.0, OctoPrint 1.4.0. The Windows 10 machine is wired and the RPi is on WiFi.


Hi there b-morgan - what did you do about the lack of printer definition for the TAZ6 in CURA 4.6? Is there another printer that's similar?

I just created my own... I used (most of) the start gcode, end gcode and any other parameters from CuraLE. I've defined both a Single Extruder and a Dual Extruder V3.