Need help using editing SD card files / using SSH

I moved houses recently and need to change the Wifi information on the MicroSD card. When I use an SD card reader, I can't access any of the files on the SD card. Only one 30MB partition shows in Windows, and it just prompts me to format it, which I haven't done. I tried using the Pi installer tool to reinstall Octoprint completely, but the SD card still only allows up to 30MB to be used, so it won't reinstall that way either.

I've also tried to connect my printer via ethernet, but the interface doesn't load, and I'm not able to SSH in either. It looks like my router isn't able to assign the Pi an IP address. Maybe ethernet is disabled on my Pi somewhere? I have a Pi 3B+.

I'm not sure what to try next since I can't SSH into the Pi. Any help is appreciated, thanks.

That boot partition should have a file on it called octopi-wpa-supplicant.txt. edit that file with a program like Notepad++ updating the wifi information.

I'm not able to find any boot partition or any readable drive. I only see the 30MB drive that asks for formatting.

I've tried looking with linux, mac, windows10, w11, using etcher, using linuxreader, and using the official pi installer, and all of them aren't able to show a readable boot partition. The pi was working just a few days ago though, so it also seems unlikely that my Pi/SD card are bricked