Need help with ELP 8mp USB camera

Camera model

elp-usb8mp04af-v72 / ELP 8mp

What is the problem?

I cant figure out how to view the stream from this USB camera

What did you already try to solve it?

I have edited octopi.txt. it is MJPG compatible so I did not add the -y parameter. I also uncommented the camera options toward the bottom in accordance to this guide. Info can be found online for the full specs but I configured it for the max supported 3264X2448 MJPEG@15fps
The stream url is the default /webcam/?action=stream
lsusb output is

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 006: ID 32e4:8430
Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

(it's Device 006: ID 32e4:8430)

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle (1.4 MB)

Additional information about your setup

Octoprint 1.9.2, Ender 3 4.2.2, Raspberry Pi 4B 4gb, Windows 10 pc, octoscreen, octoeverywhere

Not quite sure if the resolution itself is an issue or the way you set the parameters

That's the error message:
Invalid height/width '3264X2448' specified!

try a lower case x -> 3264x2448 instead of 3264X2448

If it still doesn't work, ssh into the Pi and run v4l2-ctl --list-formats-ext

That was the exact issue, kind of embarrassing copy/paste there. Lowered the case, started working immediately. Thank you :sweat_smile:


Np :slight_smile:

Happy printing :tentacle: