Need Help with OctoDash on RPi4 with Hyperpixel

What is the problem?

OctoDash not showing up

What did you already try to solve it?

Have tried serveral attempts, used various online guides

Have you tried running in safe mode?


Did running in safe mode solve the problem?


So I have followed Chris Riley's youtube tutorial to setup octoprint and octodash as well. I have installed the required drivers for Hyperpixel as well, however while running the raspi-config command the boot options have changed, now u have to go under option1 System Options > S5 Boot / Auto Login > B4 Desktop Autologin Desktop GUI, there is no option for Desktop CLI.
When i choose B4 and reboot, it takes me to a command line where it shows the URL for the octoprint server. Octodash does not show up at all.

How did you install the desktop environment on the pi?

I am sorry, i did not understand the question, i have followed Chris Riley's tutorial to install octoprint pi image. Is there an option to choose desktop version? I just defaulted everything.

We don't all know all Chris Riley's youtube tutorials by heart, so we don't know what he made you do. Perhaps you can link to the exact video you used, so we know where you are at.

1 Like

I am sorry, i understood.
This is the tutorial for Octoprint

This is hyperpixel

This is Octodash

So where in the ~52 minutes of video do you get stuck?

Actually I dont get the octodash screen.
The point where i have to choose the boot option i see this.

Also here this is what i get on the display.

I'm sorry, I am not going to watch 50 minutes of video to start guessing where you might have done something differently than in the video. It would be helpful if you told us where in the videos things are starting to behave differently from what is happening in your setup.

In the first screenshot, you are supposed to choose B4. I think you said that is what you chose, but instead of going to the desktop you get the second screenshot? Can you connect a keyboard to the Pi? If so, press enter. Do you get a login prompt?

1 Like

So the display works, and the boot options are exactly as it shows in the OctoDash video, where it says to chose console autologin?

Which matches exactly with your screenshot?

I'm confused as to what the problem is here.